Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Pressing CTRL inserts [EXT] symbols. Shortcuts using CTRL do not work.

2. Help
leance
2013-11-26
2013-11-30
  • leance
    leance
    2013-11-26

    When I press CTRL, notepad++ starts inserting ETX symbols in the document. (not one, it just starts spamming them). Pressing ALT or SHIFT does not have this problem. Shortcuts using CTRL such as CTRL+S do not work.

    See screenshot:
    http://imgur.com/pdJDYLd

    I already tried:
    Uninstalling and reinstalling, deleting AppData folder, removing all keyboard languages except US international, searching duckduckgo superuser.com portablapps.com the forum and support tickets, deleting all plugins, trying different encodings

    By the way it seems to have started after the latest update.

    I'm using
    Notepad++ unicode 5.9 built on mar 31 2011 00:24:59
    on Windows 7 x86_64

     
    Last edit: leance 2013-11-26
    • leance
      leance
      2013-11-26

      The update to v5.9.6.2 does not fix the problem.

      The update to 5.9.1 does not fix the problem.

      BTW I was using 5.9.1 until I reinstalled obviously.

      I looked it up and [ETX] seems to be ASCII char 4, a control character (for CTRL of course).

      Needless to say all the 'show characters' options are off.

       
      Last edit: leance 2013-11-26
  • Loreia2
    Loreia2
    2013-11-30

    Hi lance,

    this used to happen to me when I was using Virtual desktop manager. Desktop manager would "loose" some modal dialog window (some confirmation dialog, like "Are you sure?"), and then each press to modifier key (like Ctrl, Alt, Shift) would result in inserting random symbol. This was so annoying, I ended up removing Virtual desktop manager from my machine.

    BTW, you need to update from here (latest version is 6.5.1):
    http://notepad-plus-plus.org/

    BR,
    Loreia