Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

ANSI/UTF-8 trouble

2. Help
Bunny Toon
2010-07-15
2014-05-17
  • Bunny Toon
    Bunny Toon
    2010-07-15

    Hi there,

    I've just installed Notepad++ 5.7 and got an extremely annoying bug (I don't even know if this was buggy before). Indeed, I just can't save my PHP files in another format than ANSI. "Encoding" menu has different encoding types: i.e. I can check "Encode in UTF-8 without BOM" or "Convert to UTF-8 without BOM". Then I save the file. But if I close Notepad++ and reopen the file, it will check again "Encode in ANSI". Display bugs with French special characters on my project confirm that all my files are encoded in ANSI, as I fail converting them to UTF-8.

    Does anyone meet the same issue ?

    Greetings,

     
  • cchris
    cchris
    2010-07-15

    Attempting t view a PHP page in hungarian, with lots of accented characters, works just fine.

    Please consider that "Encode in …" commands just change the view, not the file. "Convert to …" commands do.

    This issue has been reported elsewhere, but I cannot reproduce it, using WinXP Home SP3 32 bit.

    CChris

     
  • Bunny Toon
    Bunny Toon
    2010-07-15

    Hehe, I'm actually the same person who posted in the French forum.

    I'm using the same version XP SP3 x86. I noticed that "Encode" didn't update the file so I do use "Convert" which allows me to save the file again (the floppy icon gets red). When I save the file… nothing special happens but it will remain in ANSI.

    I will make a video of it if you want.

     
  • daljun
    daljun
    2014-04-25

    First of all, note that ANSI is a misnomer, see https://sourceforge.net/p/notepad-plus/bugs/3263/

    This is not really a bug, it’s how Notepad++ used to handle character encodings. Here’s the explanation:

    UTF-8 and the Windows code pages (often incorrectly called ANSI) are supersets of the ASCII encoding. The previous setting of Notepad++ was that when a file was saved as UTF-8 without BOM and the file contains only ASCII characters, when reopening it, it used the default encoding setting ANSI (misnomer for Windows code pages).

    But since a few versions, Notepad++ uses UTF-8 without BOM as default character encoding, which makes sense, because the Windows code pages are legacy encodings. But this setting is only applied on new installations, not when you upgrade form older Notepad++ installations.

    Notepad++ also uses an incorrect term for UTF-8 without BOM: “ANSI as UTF-8”.

    That term is confusing and wrong, so it is time to correct it, see this bug report and this patch request: https://sourceforge.net/p/notepad-plus/bugs/4095/, https://sourceforge.net/p/notepad-plus/patches/571/

     
  • cchris
    cchris
    2014-05-17

    I'm being told that the video is not available.

    Can you post an actual file with the issue? Is the problem that converted to UTF-8 without BOM, but on reopening the file is believed to be in ANSI?
    (Ok, those terms may be slightly imprecise, but they are correctly understood by most people)

    CChris