Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Notepad++ V6.4.5 on winxp (Korean language support)

Bhavin
2014-02-15
2014-03-01
  • Bhavin
    Bhavin
    2014-02-15

    We are having Windows XP Proffessional with Servic Pack-3. we used Notepad++ V6.4.5 and it is working fine but now we need Korean Language Add-On on notepad++,base on that we re-installed V6.4.5 selection of localization selecting support all languages but still we are not able see korean characters,

    We would like request to you kindly help us for resolving the issue.

     
  • cchris
    cchris
    2014-02-16

    Installing the localisation will simply cause (mostly) all labels , menu entries etc to appear translated in Korean. Does this work?
    About using Korean characters: you must be able to enter them, using keyboard or some IME. And then you need a font thathas glyphs for these characters so as to show them. I think there is a Gulimche font for this purpose. Also, your document needs to be in Unicode format, preferrably UCS-2, or in a specific ANSI encoding.

    Can you report where the problem is taking place (a screenshot may be enough), and what font you are using, if he issue is to plainly read or write in Korean?

    CChris

     
  • THEVENOT Guy
    THEVENOT Guy
    2014-03-01

    Hello Bhavin,

    Although I'm French, I was quite able to display Koreean characters, in my Notepad++ v6.4.5 !

    To begin with, I had to allow management of Asiatic languages ( Configuration Panel - Linguistic and Local Options - Languages tab and checked the option "Install files for Asiatic languages ")

    => So, some Asiatic fonts were automatically added in "C:\windows\fonts". Concerning Korean language, it added the file Gulin.ttc ( 13202 Ko ) that groups together the four fonts Gulim, GulimChe, Dotum and DotumChe. See the attached picture Bhavin_1.png

    Then, in Notepad++, in Settings - Style Configurator... - Global Styles - Default Style, I chose, on the right, the font Gulim, for example and saved.

    Finally, as I can't get Korean characters from my French keyboard, I used Programs - Accessories - System Tools - Characters List ( or Characters Panel ? ) to choose, from Gulim font some Korean Characters and paste them in a new tab, in Notepad++. => It was quite OK :-) See the attached picture Bhavin_2.png

    I also try to change to the Korean encoding Windows 949 => Still OK, as well ! See the attached picture Bhavin_3.png

    NOTE : In Asiatic languages you would rather use the UCS-2 Big or Little Endian encodings, because they always need two bytes to encode any Unicode character. On the contrary, with the UTF-8 encoding, your Korean characters need three bytes to be coded => so file's length will be taller with UTF-8 encoding (-: The UTF-8 encoding is more adapted for languages with few symbols, as European, Arabic or Hebrew languages !

    Oh, BTW, these random Korean Characters, in my Test.txt file, should certainly don't mean anything in Korean language !!!

    Cheers,

    guy038

    P.S. :

    For the Windows Korean encoding, refer to the link below :

    http://msdn.microsoft.com/en-us/goglobal/cc305154

    And, for the Unicode CJK unified ideographs, refer to this link :

    http://www.unicode.org/charts/PDF/U4E00.pdf

     
    Last edit: THEVENOT Guy 2014-03-01