'ANSI as UTF-8'

2006-05-31
2014-04-25
  • I have a UTF-8 file. I know it's UTF-8 because I created it in another program and it contains oe ligatures, which are Unicode characters (œ, Œ).

    When I opened it in Notepad++, the status bar says "ANSI as UTF-8". What does this mean?

    Other Unicode files just say UTF-8.

     
    • Notepad++'s annoyances with UTF-8 is the SOLE reason I stopped using it. I need ALL my files to BE utf-8 and for some reason Notepadd++ (4.5) insisted it be something else. I had to open files in other programs like Dreamweaver and change encoding.

      I'm downloading newest version to see if anything has changed, if not, I'm sticking with Eclipse (feels bloated, but has gotta love the sysntax warnings when you make a mistake ;) )

      Oh, by the way, when will Notepad++ UPDATE ITSELF???

       
    • I think it may be that it says "ANSI as UTF-8", when the file is UTF-8 but has no BOM, and as simply UTF-8 when file does have BOM.

      This is bad, because apparently if you have a UTF-8 with BOM, it's impossible to rid of the BOM... That's a bummer, and I really thought Notepad++ was the program for me. But the ability to get rid of BOM is essential for me.

       
      • 'ANSI as UTF-8' should not mean anything. If it's UTF-8, it is usually not ANSI (which codepage anyway?). If it's both ANSI and UTF-8, it's ASCII.

         
    • You can always cut all the file content into clipboard, change the encoding and paste the content back.

       
    • A bit messed up here, but "ANSI as UTF-8" means taht the file is in UTF-8 without BOM.
      If you want your file with BOM, then select "Encode in UTF-8" in the "Format" menu.

       
    • When I first started using notepad++, I was really confused by the ansi as utf-8 deal.  I now get it that it means utf-8 without the signature, but if it would have been set up like the following, I would have understood right away.

      ANSI
      UTF-8
      UTF-16LE
      UTF-16BE
      BOM checkbox to add/remove the BOM if UTF-8, UTF-16LE or UTF16BE is selected.

      Having ANSI still selected in the menu when you're using utf-8 is a minor annoyance.