switch tabs bug

grogowar
2011-11-25
2014-04-14
  • grogowar
    grogowar
    2011-11-25

    when  "wrap" mod is on, switching between tabs works bad - when I switch to another tab and then return to first tab, I have to scroll down to position, where I was before switching to another tab. It is rather annoying always scroll down just to get position, where I was before switching.

     
  • cchris
    cchris
    2011-11-26

    Does this still happen when you rename your plugin folder, so that none at all gets loaded?

    CChris

     
  • BugA
    BugA
    2011-12-01

    Hi CChris, I can confirm this annoying behavior, too (unwanted scrolling when switching tabs), and I think all these topics are related:
    http://sourceforge.net/projects/notepad-plus/forums/forum/331754/topic/4417308
    http://sourceforge.net/projects/notepad-plus/forums/forum/331754/topic/3644888

    It happens only when View > Word wrap option is turned ON. When turned OFF, switching tabs works as expected (view stays correct). Can it be that something is miscalculated because of text breaking and thus occupying more lines with Word wrap ON, so the view is wrong (moved up)?

    For example, I`m looking at one tab at the moment, and I can see the lines from 91 to 102. When I switch to another tab, and then switch back again, I now see the lines from 84 to 92… I need to scroll back down to where I was, and this is very, very uncomfortable when working with multiple tabs and switching all the time, while I still need Word wrap turned ON :(

    The number of lines the view will move up depends on the number of long lines breaking to a new line due to word wrap, and on the size of the Notepad++ window (the less it is, the more it will get moved). When I maximize Notepad++ on 1680x1050 resolution, I can see lines from 54 to 102, and after switching to another tab and then switching back, I see lines from 51 to 99.

    Regarding your question, renaming "plugins" folder doesn`t solve it. As far as I can tell for now, it`s related to Word wrap functionality, and recalculating which lines to show in the current view, on tab switching. Word wrap makes the calculations wrong (because of long lines breaking into more then one line), and we get the wrong view.

    If it`s relative, I have "plain" Notepad++ installed, no additional plugins.

    I guess this isn`t a hard bug to fix, and I hope it`ll get fixed soon, as working like this is really painful, with all this unnecessary scrolling up and down :(

     
  • cchris
    cchris
    2011-12-01

    Do you have some scroll synchronisation (vertical likely) on? If so, this would explain somehow. I could not reproduce the problem otherwise. Anyone?

    CChris

     
  • BugA
    BugA
    2011-12-02

    Synchronize Vertical Scrolling option? Nope, not checked.

    Do you have any lines wider then the screen size? Because you need Word wrap ON, and actually lines that are wrapping. When there are no lines that break into new line (because of their length), then everything works fine. The problem appears when there are wrapping lines, and when the vertical scrollbar is shown (because you have more text than can fit in one window). When you switch to another tab, then switch back, the scrollbar has moved up a bit.

     
  • cr4shu
    cr4shu
    2012-02-28

    I confirm - there is a problem with notepad++ which is very annoying when working with many tabs. To be honest I am really baffled by the fact that this is the only topic on the internet regarding this issue… but back to business.

    As it was mentioned in order to reproduce this problem you need to have the 'word wrap' on and you need to have a file which wraps lines. Here is one:
    http://mlyniec.gda.pl/~cr4sh/np/file.txt

    Steps to reproduce:
    1. open the above file in notepad++
    2. scroll to the end of the document
    3. open a new tab in notepad++, switch to it and then switch back to the file
    4. you are no longer at the bottom of the document but at the beginning

    This is most irritating when you are trying to work at the 'end-of-file' areas.

    Regards and please fix this issue ;)
    cr4shu

     
  • Steven
    Steven
    2012-07-12

    I can confirm this, too, and I reproduced the error with the file and steps provided by cr4shu.

    I find it especially problematic because I'm using Franco Stellari's autosave plugin (sites.google.com/site/fstellari/nppplugins), which appears to quickly cycle through open tabs when it autosaves. As a result, my notepad++ jumps lines every few minutes even when I'm working in one tab but have multiple tabs open.

     
  • tjmapley
    tjmapley
    2012-10-15

    Same issue for me. When I switch back to a tab where I was working at the end of the file, I have to scroll back down. I am using v6.1.6. When I turn word wrap off, Notepad++ properly puts me back at the end of the file where I was editing when I switch back to it.

     
  • BugA
    BugA
    2012-10-15

    Yeah, still existing in version 6.1.8 (Unicode), and the latest 6.2 (just confirmed) :( This is one really, really annoying thing in working with otherwise really good (perfect?) Notepad++, and it would be reasonable if someone would finally take it into account.

    cr4shu`s file is great for testing, so thanks for that :)

     
  • Cameron
    Cameron
    2014-04-14

    still exists in 6.5.5