Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Server with no username/pass

Help
ursli
2014-07-22
2014-12-03
  • ursli
    ursli
    2014-07-22

    Hi there,

    I've tried getting this to work with a usenet server that does not need credentials to login, without success.

    Just to see if it's my configuration or something else failing I've switched to another usenet server provider which does need a username/password and the proxy worked.

    Any hints what might go wrong? The log file didn't complain about anything.

    My config:

    [server]
    use ssl = false
    host = xxx
    login =
    password =
    port = 119
    max connections = 1

    [proxy]
    use ssl = true
    port = xxx
    cert file = xxx
    cert key = xxx
    ca verification = false
    ca file = myca.pem
    logfile = /var/log/nntp2nntp.log
    pidfile = /var/run/nntp2nntp.pid

    [users]
    xxx = xxx

    [connections]
    xxx = 1

     
  • ursli
    ursli
    2014-07-25

    Thanks for the reply, I'm sorry I can't deliver better news but it still does not work it seems. Tried with 2 servers that do not need credentials to log in (both work on my local machine) and it still fails to connect with your latest revision.

    Is there a way to enable more verbose logging?

     
  • Please start the nntp2nntp.py like follows:

    $> python2.7 -O -m trace -t /usr/bin/nntp2nntp.py myconfig.conf >output.log 2>&1
    

    try to connect and send me the output.log file please, then I can look deeper on what happens.

    Thanks,
    Oleksandr

     
  • ghormoon
    ghormoon
    2014-12-03

    hi, I've got the same problem, I've tried that fix and no luck ... the setup is that I use login/pass to get to the proxy and no login/pass to the server
    I've followed that communication in tcpdump, I connect from client, receive 200 Welcome to ..., client sends authinfo user ghormoon, server sends TCP ACK, but no (text) response after that, client times out after a while and sends TCP FIN.