NITRO 2.7 installation help

Help
WSD
2013-11-01
2013-11-06
  • WSD
    WSD
    2013-11-01

    I have downloaded the src file (2.7-r1157) and I am having issues building it.

    I have tried on a RHEL5.7 32 bit and a CentOS 6.4 64 bit machine.

    xmmgr-smith> echo $NITRO_INSTALL
    /home/xmmgr/nitroInstall/

    xmmgr-smith> ./waf configure --prefix=$NITRO_INSTALL/
    Setting top to : /home/xmmgr/nitroSrc/c/nitf
    Setting out to : /home/xmmgr/nitroSrc/c/nitf/build
    'configure' finished successfully (0.003s)
    xmmgr-smith> ./waf build
    Waf: Entering directory `/home/xmmgr/nitroSrc/c/nitf/build'
    Traceback (most recent call last):
    File "/home/xmmgr/nitro/build/.waf-1.7.8-77e2cdd38ea2930f982e3aabf335fdb7/waflib/Scripting.py", line 97, in waf_entry_point
    File "/home/xmmgr/nitro/build/.waf-1.7.8-77e2cdd38ea2930f982e3aabf335fdb7/waflib/Scripting.py", line 153, in run_commands
    File "/home/xmmgr/nitro/build/.waf-1.7.8-77e2cdd38ea2930f982e3aabf335fdb7/waflib/Scripting.py", line 146, in run_command
    File "/home/xmmgr/nitro/build/.waf-1.7.8-77e2cdd38ea2930f982e3aabf335fdb7/waflib/Scripting.py", line 351, in execute
    File "/home/xmmgr/nitro/build/.waf-1.7.8-77e2cdd38ea2930f982e3aabf335fdb7/waflib/Build.py", line 106, in execute
    File "/home/xmmgr/nitro/build/.waf-1.7.8-77e2cdd38ea2930f982e3aabf335fdb7/waflib/Build.py", line 109, in execute_build
    File "/home/xmmgr/nitro/build/.waf-1.7.8-77e2cdd38ea2930f982e3aabf335fdb7/waflib/Context.py", line 128, in recurse
    File "/home/xmmgr/nitroSrc/c/nitf/wscript", line 33, in build
    env = bld.module(**globals())
    AttributeError: 'BuildContext' object has no attribute 'module'

    I also downloaded Nitro2.6 and got the same errors when I tried it, but I was able to install 2.6 if I used the old method ./configure --prefix=$NITRO_INSTALL, make && make install

    I'm sure its probably a setup issue on my machines, but I am having a hard time figuring it out.

    I am new to this and any help would be greatly appreciated.

    Thanks,
    Shawn

     
  • WSD
    WSD
    2013-11-06

    I was able to build on another machine which had a later version of python (2.6.6 vice 2.4.3)