Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#127 error parsing regex on win7 64-bit

closed-works-for-me
Amorilia
PyFFI NIF (4)
5
2011-11-29
2011-10-24
H2Odk
No

While trying to update the regex skip\only-list for oblivion I encountered a strange problem

the ini had this only list

Only = meshes\\\\clutter

this worked as intended on my XP 32-bit install. But on my Win7 64-bit I got this error:

Traceback (most recent call last):
File "C:\Python27\Scripts\niftoaster.py", line 195, in <module>
NifToaster().cli()
File "C:\Python27\lib\site-packages\pyffi\spells\__init__.py", line 1177, in cli
(options, args) = parser.parse_args()
File "C:\Python27\lib\optparse.py", line 1399, in parse_args
stop = self._process_args(largs, rargs, values)
File "C:\Python27\lib\optparse.py", line 1439, in _process_args
self._process_long_opt(rargs, values)
File "C:\Python27\lib\optparse.py", line 1514, in _process_long_opt
option.process(opt, value, values, self)
File "C:\Python27\lib\optparse.py", line 788, in process
self.action, self.dest, opt, value, values, parser)
File "C:\Python27\lib\optparse.py", line 808, in take_action
self.callback(self, opt, value, parser, *args, **kwargs)
File "C:\Python27\lib\site-packages\pyffi\spells\__init__.py", line 975, in parse_inifile
ini_parser.read(value)
File "C:\Python27\lib\ConfigParser.py", line 297, in read
self._read(fp, filename)
File "C:\Python27\lib\ConfigParser.py", line 538, in _read
raise e
ConfigParser.ParsingError: File contains parsing errors: test_optimize_01.ini
[line 15]: 'only meshes\\\\\\\\clutter'

I have Python 2.7 32-bit and PyFFI 2.1.10 installed on both.

This is probably why I avoided using '\' in the skiplist that is currently used, I made that on my win7 so never tested if it would work on XP 32-bit.

It will be a great improvement if this can be fixed.

H2Odk

Discussion

  • H2Odk
    H2Odk
    2011-10-24

    oops.. wrong project

     
  • H2Odk
    H2Odk
    2011-10-24

    • status: open --> wont-fix
     
  • Amorilia
    Amorilia
    2011-11-02

    No problem. :-) Thanks for the report. Let's just handle it here then just this once.

    I'm surprised it works under 2.7.2 (?) 32 bit but not 2.7.2 64 bit... Are you sure you were running 2.7 on your XP box?

     
  • Amorilia
    Amorilia
    2011-11-02

    • assigned_to: nobody --> amorilia
    • status: wont-fix --> open-accepted
     
  • Amorilia
    Amorilia
    2011-11-02

    • labels: --> PyFFI NIF
     
  • H2Odk
    H2Odk
    2011-11-02

    I thought I had deleted this... because the error was caused by me.. not PyFFI

     
  • Amorilia
    Amorilia
    2011-11-29

    • status: open-accepted --> closed-accepted
     
  • Amorilia
    Amorilia
    2011-11-29

    • status: closed-accepted --> closed-works-for-me