Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Library problems on Tiger

Help
2005-07-03
2013-04-22
  • Gary Elshaw
    Gary Elshaw
    2005-07-03

    This is the console when starting Nicotine under Tiger, problems with Tiger's X11 libraries by the look of it:

    XFree86 Version 4.4.0 / X Window System
    (protocol Version 11, revision 0, vendor release 6600)
    [DRI] screen 0 installation complete
    Screen 0 added: 1344x1008 @ (0,0)
    Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
    bash: no job control in this shell
    Nicotine supports "psyco", an inline optimizer for python
    code, you can get it at http://sourceforge.net/projects/psyco/
    Traceback (most recent call last):
      File "sw/bin/nicotine", line 142, in ?
        result = checkenv()
      File "sw/bin/nicotine", line 68, in checkenv
        import gtk
      File "/Applications/Nicotine/Nicotine.app/Contents/Resources/sw/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?
        from _gtk import *
    ImportError: dlopen(/Applications/Nicotine/Nicotine.app/Contents/Resources/sw/lib/python2.3/site-packages/gtk-2.0/gtk/_gtk.so, 2): Library not loaded: /usr/X11R6/lib/libXft.2.dylib
      Referenced from: /Applications/Nicotine/Nicotine.app/Contents/Resources/sw/lib/python2.3/site-packages/gtk-2.0/gtk/_gtk.so
      Reason: Incompatible library version: _gtk.so requires version 2.1.2 or later, but libXft.2.dylib provides version 2.1.0

     
    • The bug is fixed? I downloaded the new app a few minutes ago, and I still seem to be having X11 library problems. As soon as X11 opens, Nicotine crashes.

       
    • Gary Elshaw
      Gary Elshaw
      2005-07-08

      I just re-downloaded (8 July) and it's now working and looking good too! I downloaded and installed geoip and it seems to have picked that up nicely as well.

      One question, is there a reason that it seems to be an rc1 release of Nicotine when 1.0.8 went final?

       
    • Yeah, it turns out the Fink maintainer for Nicotine made a little mistake and called the 1.0.8rc1 release "1.0.8". So we're all actually running the rc1, woops.

      I intend to make a new release that uses the actual 1.0.8, with Panther support, as well as GeoIP and pyvorbis capabilities. I've tested each of these separately, but I have to make sure they work together first :-)

      I've also recently been "promoted", I'm now one of the Fink project leaders, so my life's been pretty busy lately. If anybody wants to assist with Nicotine.app, email me.

       
    • Nicotine opens up but then quits and I get this message in the console:

      Nicotine supports "psyco", an inline optimizer for python
      code, you can get it at http://sourceforge.net/projects/psyco/
      Traceback (most recent call last):
        File "sw/bin/nicotine", line 142, in ?
          result = checkenv()
        File "sw/bin/nicotine", line 68, in checkenv
          import gtk
        File "/Users/danielth/Desktop/Nicotine Folder/Nicotine 1.0.8 R3/Nicotine.app/Contents/Resources/sw/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?
          from _gtk import *
      ImportError: dlopen(/Users/danielth/Desktop/Nicotine Folder/Nicotine 1.0.8 R3/Nicotine.app/Contents/Resources/sw/lib/python2.3/site-packages/gtk-2.0/gtk/_gtk.so, 2): Library not loaded: /usr/X11R6/lib/libXinerama.1.dylib
        Referenced from: /Users/danielth/Desktop/Nicotine Folder/Nicotine 1.0.8 R3/Nicotine.app/Contents/Resources/sw/lib/python2.3/site-packages/gtk-2.0/gtk/_gtk.so
        Reason: image not found