#153 Can't install NixNote on Fedora 18

open
nobody
None
5
2014-12-05
2013-05-12
Sindhu S
No

Hello,

I am trying to install NixNote on Fedora 18 and I get the following error via yum:

udo yum localinstall ~/Desktop/software/nixnote-1.5-2.x86_64.rpm
[sudo] password for sindhu:
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Examining /home/sindhu/Desktop/software/nixnote-1.5-2.x86_64.rpm: nixnote-1.5-2.x86_64
Marking /home/sindhu/Desktop/software/nixnote-1.5-2.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package nixnote.x86_64 0:1.5-2 will be installed
--> Processing Dependency: perl(Term::ReadKey) for package: nixnote-1.5-2.x86_64
Loading mirror speeds from cached hostfile
* fedora: mirror.cse.iitk.ac.in
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-updates: mirror.cse.iitk.ac.in
* rpmfusion-nonfree: mirror.cse.iitk.ac.in
* rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
* updates: ftp.riken.jp
--> Running transaction check
---> Package perl-TermReadKey.x86_64 0:2.30-16.fc18 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
nixnote x86_64 1.5-2 /nixnote-1.5-2.x86_64 61 M
Installing for dependencies:
perl-TermReadKey x86_64 2.30-16.fc18 fedora 30 k

Transaction Summary

Install 1 Package (+1 Dependent package)

Total size: 61 M
Total download size: 30 k
Installed size: 61 M
Is this ok [y/N]: y
Downloading Packages:
perl-TermReadKey-2.30-16.fc18.x86_64.rpm | 30 kB 00:00
Running Transaction Check
Running Transaction Test

Transaction Check Error:
file / from install of nixnote-1.5-2.x86_64 conflicts with file from package filesystem-3.1-2.fc18.x86_64
file /usr/bin from install of nixnote-1.5-2.x86_64 conflicts with file from package filesystem-3.1-2.fc18.x86_64

Error Summary
-------------

How do I resolve this? Thanks.

Discussion

  • Rick R.
    Rick R.
    2013-06-15

    I just ran into the same thing trying to upgrade from nixnote-1.4 to nixnote-1.6. I ran 'rpm -Uhv nixnote-1.6-2.x86_64.rpm' and got the errors:

    Preparing... ################################# [100%]
    file / from install of nixnote-1.6-2.x86_64 conflicts with file from package filesystem-3.1-2.fc18.x86_64
    file /usr/bin from install of nixnote-1.6-2.x86_64 conflicts with file from package filesystem-3.1-2.fc18.x86_64

    This was also on Fedora-18 64-bit

     
    Last edit: Rick R. 2013-06-15
  • I use alien to create the rpm from the deb. I think there is some error from that process. The easiest thing to do is to download the tar.gz file and run the install.sh script. It should accomplish the same thing.

     
    • Rick R.
      Rick R.
      2013-06-23

      I used the install.sh script. It worked fine. Thanks.

       
  • ddreggors
    ddreggors
    2013-10-29

    I have created new spec files and built new rpms from your tar.gz packages.
    I can confirm they install fine and would share all info if interested.

     
  • Jonathan Nicol
    Jonathan Nicol
    2014-03-04

    maybe you should stop publishing known-broken rpms.

    Or since this program doesn't seem to work with a modern version of SSL, just stop publishing it altogether. Thanks for wasting my afternoon.