#141 Notes get marked as modified randomly, random conflicts

open-fixed
nobody
5
2014-01-23
2013-01-09
Bojan Jovanovic
No

Have approx 750 notes. Using nixnote on 4-5 machines, and on the phone. No two computers show the same number in the "All Notebooks" category vary approx by 5-6 notes.

Also in 1.4 on my newest box, I see the following behaviour:
- Notes occassionaly (for absolutely no valid reason) get copied to conflicting notes
- Usually around the same time a BUNCH of notes that have not been touched gets markes as sync.
- I have not confirmed any data loss yet, but very concerned with the latest behaviour

Discussion

  • You're the second person to report this. So far, I haven't been able to figure it out or recreate it locally but as far as I can tell there is no data loss, just odd conflicting notes.

    I have the other person sending me his logs, but I want to ask a couple of questions:
    - Are you using sync on startup or sync on shutdown?
    - Are you using shared notebooks?
    - Does this seem to happen when editing a tag? The other person thinks it is happining more often when editing tags so I'm trying to develop a pattern.

     
    • status: open --> closed-fixed
     
  • I believe this has been corrected with 1.5. Please let me know if you still are having problems.

     
  • Have not seen it since I moved to 1.5. Thanks for fixing it!

     
    • status: closed-fixed --> open-fixed
     
  • The issue is back. I am on 1.6 now.

    Basically getting random conflicts. Have approx 900 notes now.

    The conflict most often happens after I edit an old note, and try to sync it. It fails, although that note was not touched in a long long time. The logs show:
    2014-01-23 02:37:48.792 ---
    2014-01-23 02:38:22.321 dirty count: 1
    2014-01-23 02:38:22.321 Dirty Notes Before Sync: 1
    2014-01-23 02:38:22.321 Dirty Notes:
    2014-01-23 02:38:22.322 Dirty local notes: 1
    2014-01-23 02:38:22.322 0 : a4194846-3e4d-4c22-ae96-9f80a1467f13 : DNS stuff
    2014-01-23 02:38:22.745 Full Sequence Before: 1332366709000
    2014-01-23 02:38:22.745 Last Sequence Date: 1390444306322
    2014-01-23 02:38:22.746 Var Last Sequence Number: 299412
    2014-01-23 02:38:22.746 DB Last Sequence Number: 299412
    2014-01-23 02:38:22.746 Update Count: 299412
    2014-01-23 02:38:22.746 Last Update Count: 299412
    2014-01-23 02:38:23.177 Dirty local notes: 1
    2014-01-23 02:38:23.177 dirty count: 1
    2014-01-23 02:38:23.177 Dirty local notes found: 1
    2014-01-23 02:38:23.178 Dirty local notes: 1
    2014-01-23 02:38:23.397 *** EDAM User Excepton syncLocalNotes EDAMUserException(errorCode:DATA_CONFLICT, parameter:Note.deleted)
    2014-01-23 02:38:23.397 EDAMUserException(errorCode:DATA_CONFLICT, parameter:Note.deleted)
    2014-01-23 02:38:23.398 dirty count: 1
    2014-01-23 02:38:23.398 Dirty Notes After Sync: 1
    2014-01-23 02:38:23.399 Dirty Notes:
    2014-01-23 02:38:23.399 Dirty local notes: 1
    2014-01-23 02:38:23.399 0 : a4194846-3e4d-4c22-ae96-9f80a1467f13 : DNS stuff
    2014-01-23 02:38:23.400 ---

    Note, the note has NOT been deleted elsewhere and was just fine up to a minute ago.. The only way to "resolve" this is to save the content elsewhere, delete it locally, sync, and then create a new one with the same title.. By now happens twice a day to me (use nixnote quite a bit on a few boxes, approx 950 notes)..

    Thanks,
    Bojan

    PS If this is a different issue, please move it to a new one.

     
    Last edit: Bojan Jovanovic 2014-01-23