#135 Not installable on Debian Wheezy


Since libssl0.9.8 is removed from current testing, which will become Debian Wheezy, nixnote 1.4 is not (and will not) be installable on Debian Wheezy (or current testing).
When replacing libssl0.9.8 to libssl1.0.0 in the control file (and gz and repackage it with "ar -r nixnote-1.4-fixed_amd64.deb debian-binary control.tar.gz data.tar.gz") I could install the package.
When I ran it from the CLI I got the following output:
$ nixnote
QtJambiInternal.buildMetaData: Writer for property content takes a type which is incompatible with reader's return type.
QSslSocket: cannot call unresolved function SSLv3_client_method
QSslSocket: cannot call unresolved function SSL_CTX_new
QSslSocket: cannot call unresolved function SSL_library_init
QSslSocket: cannot call unresolved function ERR_get_error
QSslSocket: cannot call unresolved function ERR_error_string

It looks like I can use it, but don't know the consequences of those error msgs.
I read somewhere that nixnote (or qt?) doesn't like libssl1.0.0 but when used on Debian Wheezy (and later versions) there's not much of an option afaik.
If you want me to provide more details or test sth or ... let me know.

Thanks for the great application!



  • You will probably have issues synchronizing. The problem is that Qt Webit requires SSL 0.9 to do an HTTPS connection web page. That HTTPS connection is needed to get the OAuth token to be able to synchronize. Once the OAuth token is received, you don't need to use libssl 0.9 for another year. Unfortunately, I cannot alter the libssl 0.9 requirement.

    You may be able to still synchronize, but it really depends upon the distro. Some seem to still work, but others don't. I haven't found a rhyme or reason why some work with 1.0 & others don't.

  • Rainer Koenig
    Rainer Koenig

    You can download the old libssl0.9.8 package from Squeeze and install it by hand. Then the dependency issue is solved.