#584 64 bit, ssh X11 forwarding: nedit X connection breaks

release
closed-invalid
Motif (9)
5
2007-07-13
2007-03-02
Reiner
No

running 64 bit ubuntu server LTS 6.01 (2.6.15-28-amd64-server kernel) on a dual core Xeon rack server. running 32 bit ubuntu desktop LTS 6.01 on my dual core Xeon desktop. version of nedit is the same on both platforms (so are the versions of the other packages that nedit depends on: lesstif2, libc6, libice6, libsm6, libx11-6, libxext6, libxp6, libxt6).

version on server:
Built on: Linux, x86-64, GNU C
Built at: Oct 8 2005, 20:15:23
With Motif: 2.1.0 [@(#)GNU/LessTif Version 2.1 Release 0.93.94] (UNTESTED)
Running Motif: 2.1 [unknown]
Server: The X.Org Foundation 70000000
Visual: 24-bit TrueColor (ID 0x21, Default)
Locale: en_GB.UTF-8

version on desktop:

Built on: Linux, 486, GNU C
Built at: Oct 8 2005, 20:13:19
With Motif: 2.1.0 [@(#)GNU/LessTif Version 2.1 Release 0.93.94] (UNTESTED)
Running Motif: 2.1 [unknown]
Server: The X.Org Foundation 70000000
Visual: 24-bit TrueColor (ID 0x21, Default)
Locale: en_GB.UTF-8

after ssh -X -v -v <server> and calling nedit, nedit fails to open a window and i get this:

debug1: client_input_channel_open: ctype x11 rchan 3 win 65536 max 16384
debug1: client_request_x11: request from 127.0.0.1 38848
debug2: fd 7 setting O_NONBLOCK
debug1: channel 1: new [x11]
debug1: confirm x11
debug2: channel 1: rcvd adjust 33696
debug2: channel 1: read<=0 rfd 7 len -1
debug2: channel 1: read failed
debug2: channel 1: close_read
debug2: channel 1: input open -> drain
debug2: channel 1: ibuf empty
debug2: channel 1: send eof
debug2: channel 1: input drain -> closed
debug2: channel 1: write failed
debug2: channel 1: close_write
debug2: channel 1: output open -> closed
debug2: channel 1: send close
X connection to localhost:10.0 broken (explicit kill or server shutdown).
debug2: channel 1: rcvd close
debug2: channel 1: is dead
debug2: channel 1: garbage collecting
debug1: channel 1: free: x11, nchannels 2

after ssh -X -v -v <desktop> and calling nedit, everything is fine and i get this:

debug1: client_input_channel_open: ctype x11 rchan 3 win 65536 max 16384
debug1: client_request_x11: request from 127.0.0.1 60257
debug2: fd 7 setting O_NONBLOCK
debug1: channel 1: new [x11]
debug1: confirm x11
debug2: channel 1: rcvd adjust 34164
debug2: channel 1: rcvd adjust 36456
debug2: channel 1: window 64284 sent adjust 66788
debug2: channel 1: window 64944 sent adjust 66128
debug2: channel 1: rcvd adjust 33280

things like xlogo, xemacs and synaptic, when started on the server, display remotely on my desktop w/o problems.

built nedit from source on server. made no difference. same behavior.

this is an obscure bug to me, and i'd appreciate any hint on how to track it down to its source.

Discussion

<< < 1 2 (Page 2 of 2)
  • Scott Tringali
    Scott Tringali
    2007-07-13

    • assigned_to: nobody --> tringali
    • labels: 355502 --> Motif
    • milestone: --> release
    • status: open --> closed-invalid
     
  • Scott Tringali
    Scott Tringali
    2007-07-13

    Logged In: YES
    user_id=11321
    Originator: NO

    Seems to be a Motif issue.

     
<< < 1 2 (Page 2 of 2)