#567 Copy/Paste stops working

release
open
nobody
Program (402)
5
2006-11-13
2006-11-13
vassili_m
No

In a case if the NEdit session is lasting very long (a
week), at some instant the Copy/Paste stops working
completely, both for the keybord shortcuts
(ctrl-C/ctrl-V) and the Edit menu entries. The bug
observed for:

NEdit 5.5
Sep 30, 2004

Built on: Linux, 386, GNU C
Built at: Oct 1 2004, 15:55:40
With Motif: 2.1.30 [@(#)Motif Version 2.1.30]
Running Motif: 2.1 [unknown]
Server: The XFree86 Project, Inc 40300000
Visual: 24-bit TrueColor (ID 0x22, Default)
Locale: en_US.UTF-8

OS:

Scientific Linux CERN 2.4.21-37.EL.cernsmp #1 SMP
Tue Oct 4 16:29:11 CEST 2005 i686 GNU/Linux

KDE 3.1.3-6.10 Red Hat

Discussion

<< < 1 2 (Page 2 of 2)
  • freezergirl
    freezergirl
    2007-06-20

    Logged In: YES
    user_id=1823528
    Originator: NO

    Regarding numlock: didn't seem to make any difference for me. I turned it on and off back and forth and it did NOT solve the copy/paste problem. I'm using ssh -X on FreeBSD.

     
  • Logged In: NO

    I have not been able to paste from a windows editor (like notepad) into nedit, I can copy
    FROM Nedit and paste into other places, but not the other way around.

     
  • Logged In: NO

    I'm facing the same problem on debian Linux.
    After many tests, I concluded that copy/paste disappeared after paste by drag and drop between two different nedit panes.
    I have to logoff and logon to make it work again

     
  • I'm having the same cut/paste issue with the following linux build. I don't have anything diagnostic information to add other than it effects this flavor of linux too.

    Built on: Linux, x86-64, GNU C
    Built at: Sep 20, 2004 05:43:18
    With Motif: 2.2.3 [@(#)Motif Version 2.2.3]
    Running Motif: 2.2 [unknown]
    Server: The X.Org Foundation 70`0`000
    Visual: 32-bit TrueColor (ID 0x3d)
    Locale: en_US

     
  • Well, it's 2010 and the problem is still around. I also have no idea what is causing it, but quitting all nedit processes seems to fix it, only for it to break a few minutes later. I'm also on the verge of switching browser. Only in my case, it's stranger still: I have the same distribution (Fedora 12) both at work and at home, however, at work it seems to break whereas at home it doesn't.

    At work I have a dual screen setup with separate desktops (:0.0 and :0.1), whereas at home I have only a single screen.

    I run it with XLIB_SKIP_ARGB_VISUALS=1 to avoid redraw problems.

    My NEdit version info is below:

    NEdit 5.5
    Sep 30, 2004

    Built on: Linux, Pentium Pro, GNU C
    Built at: Jul 27 2009, 00:40:51
    With Motif: 2.1.0 [@(#)GNU/LessTif Version 2.1 Release 0.95.0] (UNTESTED)
    Running Motif: 2.1 [unknown]
    Server: Fedora Project 10706000
    Visual: 24-bit TrueColor (ID 0x21, Default)
    Locale: en_CA

     
  • Well, it's 2010 and this bug is still around. Strangely, I have 2 computers that
    both have the same setup (Fedora 12), and it only seems to happen on one of
    them. At work, I have a dual screen setup with separate desktops (:0.0 and :0.1)
    whereas at home I have only one screen. This happens to me at work but not at
    home.

    I've tried the NumLock workaround, but it didn't help. Ctrl/Shift+Insert doesn't
    work for me at all. Please tell me a better workaround or a fix has been
    discovered in the meantime.

    I'm using XLIB_SKIP_ARGB_VISUALS=1 to avoid the redraw problems, even though I'm
    not using compiz for my window manager. My window manager is metacity. My
    desktop is GNOME.

    Here's some of the info from Help->Version:

    NEdit 5.5
    Sep 30, 2004

    Built on: Linux, Pentium Pro, GNU C
    Built at: Jul 27 2009, 00:40:51
    With Motif: 2.1.0 [@(#)GNU/LessTif Version 2.1 Release 0.95.0] (UNTESTED)
    Running Motif: 2.1 [unknown]
    Server: Fedora Project 10706000
    Visual: 24-bit TrueColor (ID 0x1aa, Default)
    Locale: en_CA

     
  • Oh, so comments get added to the top. Oops :) Sorry for the dupe.

     

  • Anonymous
    2010-11-23

    I have the same problem on CentOS 5. It's extremely annoying since I work with a dozen or more desktops, all of which have nedit sessions in them. Only way I can get copy/paste working is to kill all the nedit instances. I have developed a script that makes a list of all the nedit processes and reopens them, but it doesn't put them in the proper desktop. I wish there was a good replacement for nedit, it doesn't look like this irritating bug will ever be fixed.

     
<< < 1 2 (Page 2 of 2)