#402 Detaching a tab from a tabbed window diminishes size

development
closed-fixed
nobody
Program (402)
4
2004-09-15
2004-08-18
Wally Crooze
No

Version:
NEdit 5.5RC1
Jul 23, 2004

Built on: Linux, 386, GNU C
Built at: Jul 24 2004, 13:45:55
With Motif: 2.1.30 [@(#)Motif Version 2.1.30]
Running Motif: 2.1 [unknown]
Server: The X.Org Foundation 60700000
Visual: 24-bit TrueColor (ID 0x23, Default)
Locale: C

Procedure:
1. Open a window with a few tabs.
2. From window open new window.

Result:
Second window takes its size from the proceding windows
text pane size, which is reduced due to the tabs.

Suggestions:
Either:
1. Tabs don't decrease text pane size... but instead
increases window size.
2. New window size is same as previous window size,
rather than from text pane size.

Opinion:
I'd prefer 1, but would concede to accept 2 - if necessary.
If others differ in opinion, then maybe an option to
control whether window size or text pane size is effected.

Discussion

  • Nathan Gray
    Nathan Gray
    2004-08-18

    Logged In: YES
    user_id=121553

    Cannot reproduce on Mac OS X. The new window has the same size as
    the original window. In other words, the new window's text widget is
    larger because it has no tabs.

     
  • Thorsten Haude
    Thorsten Haude
    2004-08-18

    Logged In: YES
    user_id=119143

    I can confirm this with RC1 running on Sarge.

     
  • TK Soh
    TK Soh
    2004-08-23

    Logged In: YES
    user_id=411637

    Which motif you are linking to? Please post the output of
    nedit -V.

     
  • TK Soh
    TK Soh
    2004-08-23

    Logged In: YES
    user_id=411637

    BTW, unless there're changes that I am not aware of, all new
    windows should be created with the default settings. The
    new window does not inherit anything AFAIK from the
    invoking window.

     
  • Thorsten Haude
    Thorsten Haude
    2004-08-23

    Logged In: YES
    user_id=119143

    I don't understand. I thought the linux binaries are static?
    Anyway, I see the same thing on SuSE 9.1:
    NEdit 5.5RC1
    Jul 23, 2004

    Built on: Linux, 386, GNU C
    Built at: Jul 24 2004, 13:45:55
    With Motif: 2.1.30 [@(#)Motif Version 2.1.30]
    Running Motif: 2.1 [unknown]
    Server: Hummingbird Communications Ltd. 6200
    Visual: 24-bit TrueColor (ID 0x22, Default)
    Locale: de_DE.UTF-8

     
  • TK Soh
    TK Soh
    2004-08-23

    Logged In: YES
    user_id=411637

    I made no assumption your were using the official binaries. In
    any case, I could not reproduce the bug. The new windows
    always respect my "Initial Window Size" setting - 40x80 in my
    case.

     
  • Thorsten Haude
    Thorsten Haude
    2004-08-23

    Logged In: YES
    user_id=119143

    Try the following:
    0. Unset "Hide Tab Bar when only one Document is open"
    setting
    1. Open two tabs in one window.
    2. Open a new window.
    3. Open tab in new window.

    Result: The second window (and its text panes) is smaller
    than the first.

    Do you see this?

     
  • Nathan Gray
    Nathan Gray
    2004-08-23

    Logged In: YES
    user_id=121553

    On OS X from CVS, when I follow that procedure the new window is
    *larger* than the original one. If I change the pref from always showing
    the tab bar to hiding the tab bar when only one file is open
    (checkbox goes from unchecked to checked) then the new window is
    smaller. However, the windows don't keep getting smaller and smaller,
    all subsequently opened windows are the same size.

    This only happens during the session where I change the "Hide tab bar"
    preferences setting. If I save defaults and restart then I don't see any
    problem in future NEdit sessions. If that's true on other platforms then I
    don't think we should let this bug hold up the release.

     
  • Thorsten Haude
    Thorsten Haude
    2004-08-23

    • priority: 5 --> 4
     
  • Thorsten Haude
    Thorsten Haude
    2004-08-23

    Logged In: YES
    user_id=119143

    Doh, I meant to say *set* the setting. Whatever, you
    obviously found the matching error making the window larger.

    Indeed, I don't see this if the pref is already set if NEdit
    is started. This should be postponed until after the release.

     
  • TK Soh
    TK Soh
    2004-08-24

    Logged In: YES
    user_id=411637

    You can call it whatever you want, but it's not really a bug.
    This behavior is by design - we chose not to resize the
    window when we show/hide the toolbar components.
    Similarly, if you disable/enable the statsline or i-search line of
    one window, then open a new window from it - you get a
    text pane of different size in the new window too. Though
    you may argue.

    This 'behavior' can be changed, if so desired.

     
  • Nathan Gray
    Nathan Gray
    2004-08-24

    Logged In: YES
    user_id=121553

    TK, I think you're misunderstanding. The outer frame of the window
    changes size, not just the text widget, so the two NEdit windows side by
    side differ in size by the height of the tab bar. It looks like the height for
    new windows (or some component of it) is calculated assuming the tab
    bar is there (or not there) and then it isn't updated when the preference
    changes. It's very minor but I think it's a bug.

     
  • TK Soh
    TK Soh
    2004-08-24

    Logged In: YES
    user_id=411637

    OK. I'll need to take a look later.

     
  • TK Soh
    TK Soh
    2004-08-24

    Logged In: YES
    user_id=411637

    I took a look again, and I still think, or confused, in the same
    way.

    The 2nd window has the larger size because it's text pane is
    created with the size specified by the "Initial Window Size"
    setting, plus the tab bar which is now always shown. The 1st
    window has a smaller size because when the "Hide Tab bar.."
    setting was disabled, or when more one tab is opened, it's
    tab bar shows up and occupy the space taken earlier by the
    text pane - which effectively shrinked the text pane(s).

    As far as I can see, the 2nd window has the right size - it's
    text pane's size respect the preference setting. So the first
    idea I have in fixing this 'bug' will be to resize the first
    window, whenever we toggle the toolbar components, in
    order to maintain the size of the text pane(s). This may bring
    us back to the shrinking-window bug we had earlier.

     
  • Thorsten Haude
    Thorsten Haude
    2004-08-24

    Logged In: YES
    user_id=119143

    I see you point. The size is dominated by the text widget's,
    not the window's size. I think what throw me off track here
    is that the text widget is resized if a new tab is opened
    (if the "Hide Tab Bar..." setting is set). That is of course
    preferencable, so no point arguing it.

    Wally, what do you think?

     
  • Wally Crooze
    Wally Crooze
    2004-08-24

    Logged In: YES
    user_id=530199

    I concur. When I first opened the bug I thought it was
    continuously diminishing... but I think I was just imagining
    it (I've recently been ill).

     
  • Nathan Gray
    Nathan Gray
    2004-08-31

    Logged In: YES
    user_id=121553

    I've found a way to get perpetually shrinking windows:
    1. Open two files with tabs enabled but set the tab bar to hidden for
    single documents.
    2. Detach one tab -- the new window will be smaller than the original.
    3. In the smaller window, open a second document.
    4. Detach one tab -- the new window will be even smaller than the
    second window.

    You can keep doing this until the window is very very small. Basically, it
    looks like the height of the new window is calculated based on the
    presence of the tab bar in the original window. The new window only
    has one document, however, so the tab bar doesn't show.

    And no, the number of lines displayed in the text widget is not constant:
    Window 1 without tab bar: 50 lines
    Window 1 with tab bar: 48 lines
    Window 2 without tab bar: 47 lines
    Window 2 with tab bar: 45 lines
    Window 3 without tab bar: 44 lines
    Window 3 with tab bar: 42 lines
    etc...

    Actually, it looks like the off-by-one error (48 to 47, 45 to 44) is not
    restricted to the case where you set the tab bar to hidden for single
    documents. If I set the tab bar to always show I still get detached
    windows that are one line shorter than the originals.

     
  • Nathan Gray
    Nathan Gray
    2004-08-31

    Logged In: YES
    user_id=121553

    Should be fixed in CVS. The fix won't make it for RC2 but will be there
    for 5.5 (or RC3 if such a thing proves necessary).

     
  • Wally Crooze
    Wally Crooze
    2004-09-01

    Logged In: YES
    user_id=530199

    I think the scenario outlined by n8gray is what originally
    caused my problem.

     
  • Nathan Gray
    Nathan Gray
    2004-09-01

    Logged In: YES
    user_id=121553

    I have renamed the bug to more accurately reflect the actual problem.

     
  • Nathan Gray
    Nathan Gray
    2004-09-01

    • summary: Openning new window from a tabbed window diminishes size --> Detaching a tab from a tabbed window diminishes size
     
  • Nathan Gray
    Nathan Gray
    2004-09-15

    • status: open --> closed
     
  • Nathan Gray
    Nathan Gray
    2004-09-15

    • status: closed --> closed-fixed