#331 NEdit 5.4RC2 Mac OS X 10.3 build fails

development
closed-works-for-me
Nathan Gray
5
2004-07-07
2003-11-13
Anonymous
No

Apple provides it's own implementation with OS X
v10.3. I am using that and OpenMotif v2.2.
OpenMotif installs itself into /usr/local.

In order to build NEdit with this configuration, LIBS
in Makefile.macosx needs to be changed to:

LIBS= ${MOTIFLIB} -bind_at_load -L/usr/X11R6/lib
/usr/local/lib/libXm.2.dylib -lm -lXpm \ -lXext -lXt -lSM -lICE -lX11

Discussion

  •  
    Attachments
  • Logged In: NO

    You shouldn't ignore the check_tif_rule.
    If you can't port Openmotif 2.1.30 on the Mac better
    use Lesstif 93.91 (or 93.18). Otherwise the simple change in
    the makefile above will be your smaller problem.

    -- Joerg

     
  • Nathan Gray
    Nathan Gray
    2003-11-14

    Logged In: YES
    user_id=121553

    There is a version of OpenMotif 2.1.30 for OS X here:
    http://msg.ucsf.edu:8100/~eric/

    Uninstall OM 2.2 and use this one instead. Then your makefile
    change should work and you should get a good build.

    I've just committed a reworked Makefile.macosx to CVS. Can you
    try building with it? You may need to edit it somewhat to point at
    the correct version of Motif.

     
  • Nathan Gray
    Nathan Gray
    2004-07-07

    • assigned_to: nobody --> n8gray
    • status: open --> closed-works-for-me
     
  • Nathan Gray
    Nathan Gray
    2004-07-07

    Logged In: YES
    user_id=121553

    Closing for lack of feedback.