#221 Closing editor window kills nedit server

closed-duplicate
nobody
Program (402)
9
2006-10-23
2002-10-20
Anonymous
No

On RedHat 7.3 or 8.0 I very often get a problem with
nedit server simply closing down when I close one of
the open windows. It's a bit difficult to reproduce
consistently but to me it happens at least 5 or 6 times
every day.
I typically always start an nedit session using nc and
from there on use nc or ^O to open all new windows.
When the problem occurs I get the following error
message in the xterm where I started nedit session:
Error: XtPopdown requires a subclass of shellWidgetClass

Taking the hint from the news I have tried set my LANG
to en_US on RH8, but that didn't help.

The problem happens with released 5.3 as well as with
the latest CVS version.

Discussion

  • Shawn Walker
    Shawn Walker
    2002-10-28

    Logged In: YES
    user_id=2483

    I can confirm this on two seperate RedHat 8.0 systems here.
    It makes NEdit extremely annoying to use. I've filed a bug
    report with RedHat, but I haven't had any replies from them
    yet. I've tried the CVS version and even older versions of
    NEdit like the 5.1.x series. My only guess is that there's
    something screwy with the version of OpenMotif they're
    using. Help?

     
  • Thorsten Haude
    Thorsten Haude
    2002-10-28

    Logged In: YES
    user_id=119143

    Did you try a pre-compiled binary from www.nedit.org? Could
    you post the result of
    nedit -V
    if that doesn't help?

     
  • Shawn Walker
    Shawn Walker
    2002-10-28

    Logged In: YES
    user_id=2483

    I'm trying out the binary from the site right now.
    Unfortunately with that one I had to start it by doing:

    LANG=C; nedit

    I couldn't just start it normally, if I did it would crash
    when I went to the open file dialog.

    I will do the nedit -V even if the precompiled one works on
    the CVS version of NEdit and let you know what I get later
    today.

    Thanks.

     
  • Shawn Walker
    Shawn Walker
    2002-10-28

    Logged In: YES
    user_id=2483

    This is the nedit -V output of the CVS version I built:

    NEdit release of Oct 25, 2002

    Built on: Linux, 386, GNU C
    Built at: Oct 28 2002, 10:00:00
    With Motif: 2.2.3 [@(#)Motif Version 2.2.2]
    Running Motif: 2.2
    Server: The XFree86 Project, Inc 40200000
    Visual: Id 0x21 TrueColor 24 bit (Default)

    So far it appears that the precompiled binary works just
    fine, which leads me to conclude that I was right about the
    OpenMotif version they're using being b0rked.

    This is what the precompiled binary gives with nedit -V:

    NEdit 5.3
    Jun 1, 2002

    Built on: Linux, x86, GNU C
    Built at: Jun 7 2002, 11:41:04
    With Motif: 2001 [@(#)Motif Version 2.1.30]
    Running Motif: 2001
    Server: The XFree86 Project, Inc 40200000

    Where can I get the version of Motif that was used to build
    the precompiled one? I can rebuild with that and see if it
    fixes it for me.

     
  • Andrew Hood
    Andrew Hood
    2002-10-28

    Logged In: YES
    user_id=36856

    We use and recommend OpenMotif 2.1.30
    RH's web pages say it is in 7.3 Otherwise try rpmfind.
    When all else fails you can search for the source and build
    it yourself.

     
  • Shawn Walker
    Shawn Walker
    2002-10-28

    Logged In: YES
    user_id=2483

    I've been using the binary from the site all day, it appears
    to work fine other than the LANG=C workaround which I'm
    guessing is due to some bad local handling?

    Anyway. I'll try getting OpenMotif 2.1.30 and compiling
    their version with that to see what I get.

     
  • Shawn Walker
    Shawn Walker
    2002-10-28

    Logged In: YES
    user_id=2483

    Actually rpmfind.net lists OpenMotif 2.2.x for RedHat 7.3

    Is there anyway to find out what in OpenMotif 2.2 is causing
    this?

     
  • Logged In: NO

    Thanks for the idea - absolutely right - I found OpenMotif
    2.1 and rebuilt nedit on both 7.3 and 8.0 with it and have
    not had any problems since...

     
  • Logged In: NO

    Okay, I'm still seeing this no matter what verion of nedit I
    use, especially if I open lots of files at a time.

     
  • Thorsten Haude
    Thorsten Haude
    2004-07-15

    • priority: 5 --> 7
     
  • Thorsten Haude
    Thorsten Haude
    2006-09-30

    • priority: 7 --> 9
     
  • Yuriy Syrota
    Yuriy Syrota
    2006-10-12

    Logged In: YES
    user_id=1073962

    This bug seems to be reported in OpenMotif's bugzila (
    http://bugs.motifzone.net/show_bug.cgi?id=1237 ). But it was
    fixed in version 2.2.3.

     
  • Thorsten Haude
    Thorsten Haude
    2006-10-23

    Logged In: YES
    user_id=119143

    Eddy, can you confirm?

     
  • Thorsten Haude
    Thorsten Haude
    2006-10-23

    Logged In: YES
    user_id=119143

    Eddy, can you confirm?

     
  • Eddy De Greef
    Eddy De Greef
    2006-10-23

    • status: open --> closed-duplicate
     
  • Eddy De Greef
    Eddy De Greef
    2006-10-23

    Logged In: YES
    user_id=73597

    Yes, this is fixed in OM 2.2.3.