#193 Calltips crashes

development
closed-fixed
Nathan Gray
Program (402)
4
2003-05-23
2002-08-30
Thorsten Haude
No

When I try to display calltips, NEdit crashes:
- - - -
X Error of failed request: BadMatch (invalid parameter
attributes)
Major opcode of failed request: 1 (X_CreateWindow)
Serial number of failed request: 12315
Current serial number in output stream: 12319
- - - -

- - - -
NEdit release of Aug 13, 2002

Built on: Solaris, Sparc, GNU C
Built at: Aug 30 2002, 09:20:28
With Motif: 1.2.6 [@(#)OSF/Motif Version 1.2.6]
Running Motif: 1.2
Server: Sun Microsystems, Inc. 3600
- - - -

Please tell me how I can help to solve the problem.

Discussion

  • Logged In: YES
    user_id=81393

    Aha, Solaris / BadMatch ... do you have, by chance, a X
    server with 24 bit (true color) capabilities but the default
    visual set to 8 bit (for example PseudoColor) - see output
    of xdpyinfo?

    Does the crash disappear if the X-Resource ($XAPPLRESDIR/NEdit)

    nedit.visualID:PseudoColor

    is set? If so, it seems related to bug #526981
    (Unfortunately I still don't know a real solution ...)

     
  • Thorsten Haude
    Thorsten Haude
    2002-08-30

    Logged In: YES
    user_id=119143

    zsh: command not found: xdpyinfo

    So I have no idea. Could someone point out a tutorial about
    X and colors?

    I tried "-xrm '*visualID: PseudoColor'" and that fixes it
    indeed (and also works with Scott's theme patch).

     
  • Thorsten Haude
    Thorsten Haude
    2002-08-30

    Result of xdpyinfo

     
    Attachments
  • Thorsten Haude
    Thorsten Haude
    2002-08-30

    Logged In: YES
    user_id=119143

    Found a copy of xdpyinfo.

     
  • Scott Tringali
    Scott Tringali
    2002-10-04

    Logged In: YES
    user_id=11321

    Sounds like yours. Perhaps the shell creation isn't using
    the special wrappers that fix up the visual/colormap?

     
  • Scott Tringali
    Scott Tringali
    2002-10-04

    • milestone: 103146 --> development
    • priority: 5 --> 7
    • assigned_to: nobody --> n8gray
     
  • Eddy De Greef
    Eddy De Greef
    2003-04-10

    Logged In: YES
    user_id=73597

    I've looked at the calltip shell creating code, and I think
    Scott is right. It's just creating a bare popup shell,
    without taking into account the visual or colormap, so I
    wouldn't be surprised it that's what causing the crashes.
    I'll try to come up with a fix.

     
  • Eddy De Greef
    Eddy De Greef
    2003-04-10

    Logged In: YES
    user_id=73597

    I've uploaded a patch that creates the calltip shells with
    similar visual and colordepth precautions as for the other
    shells and dialog.
    I don't have multiple visuals, though, so I cannot really test.

    Can anyone have a look at it and/or try it with different
    visual before I commit it?

     
  • Eddy De Greef
    Eddy De Greef
    2003-04-10

     
    Attachments
  • Scott Tringali
    Scott Tringali
    2003-04-10

    Logged In: YES
    user_id=11321

    I tried this and it avoids the crash. Commit away. The
    color is incorrect, but I think we can work that at a lower
    priority.

     
  • Eddy De Greef
    Eddy De Greef
    2003-04-10

    Logged In: YES
    user_id=73597

    Ok, thanks. In the mean time I've also been able to
    reproduce the crash and validate the fix at home.
    I also get weird colors when I use a DirectColor visual, but
    not only for the calltips, also for menus, selections, help
    windows, ...

     
  • Eddy De Greef
    Eddy De Greef
    2003-04-10

    • status: open --> open-fixed
     
  • Nathan Gray
    Nathan Gray
    2003-04-16

    Logged In: YES
    user_id=121553

    Sounds like you guys figured it out. Great work!

     
  • Nathan Gray
    Nathan Gray
    2003-04-16

    • status: open-fixed --> closed-fixed
     
  • Nathan Gray
    Nathan Gray
    2003-04-16

    • priority: 7 --> 4
    • status: closed-fixed --> open-fixed
     
  • Nathan Gray
    Nathan Gray
    2003-04-16

    Logged In: YES
    user_id=121553

    Maybe I was too hasty closing this bug since you still
    see color problems. I'm lowering the priority instead.

     
  • Nathan Gray
    Nathan Gray
    2003-04-18

    Logged In: YES
    user_id=121553

    edg says that my CVS commit on 17 Apr 2003 for calltip
    color resources fixed the color problems he was seeing.
    Can anybody else try it out and comment?

     
  • Eddy De Greef
    Eddy De Greef
    2003-05-23

    • status: open-fixed --> closed-fixed