Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#161 Consistency check ptvl failed

open
nobody
None
3
2007-12-27
2002-05-05
Christian B.
No

I was editing 5 or 6 files, using copy & paste,
searching by regular expressions and then I saw
"Consistency check ptvl failed" six times in my
terminal window. I start nedit seldom from a terminal
window, so I cannot say how often it had appeared
before. I found the string in textDisp.c in function
posToVisibleLineNum. I have no idea what it means or
how critical this is. So far nedit did not crash.

Version info:

NEdit Version 5.2
October 2001

Built on: NetBSD, x86, GNU C
Built at: Apr 9 2002, 03:42:54
With Motif: 2001 [@(#)Motif Version 2.1.30]
Running Motif: 2001
Server: The XFree86 Project, Inc 40200000

Discussion

  • Eddy De Greef
    Eddy De Greef
    2002-05-06

    Logged In: YES
    user_id=73597

    It is probably not that critical.
    There have been some fixes in the post-5.2 code that could
    be related.
    Are you using continuous wrapping and a variable-width font?

     
  • Christian B.
    Christian B.
    2002-05-06

    • priority: 5 --> 3
     
  • Christian B.
    Christian B.
    2002-05-06

    Logged In: YES
    user_id=225871

    Yes, I use continuous wrapping.

    This is my primary font:
    -adobe-courier-medium-r-normal--12-*-*-*-*-*-*

    AFAIK this is the default setting and I haven't changed it.

    BTW, can I safely use "nedit 2> /tmp/nedit.stderr" to
    collect all error messages which might appear or is that
    problematic with using the "Shell Menu"?

     
  • Eddy De Greef
    Eddy De Greef
    2002-05-07

    Logged In: YES
    user_id=73597

    Can you also say what your italic, bold, and italic/bold
    fonts are ? (grep Font ~/.nedit)
    The problem that I was refering to also occurs when these
    fonts have different widths.

    I don't think that there is a risk of interfering with the
    shell menu commands if you redirect stderr.

    If it is easy to reproduce those messages, you can try
    5.3RC1 to see whether it still has the same problem.

     
  • Christian B.
    Christian B.
    2002-05-07

    Logged In: YES
    user_id=225871

    nedit.textFont:
    -adobe-courier-medium-r-normal--12-*-*-*-*-*-*
    nedit.boldHighlightFont:
    -adobe-courier-bold-r-normal--12-*-*-*-*-*-*
    nedit.italicHighlightFont:
    -adobe-courier-medium-o-normal--12-*-*-*-*-*-*
    nedit.boldItalicHighlightFont:
    -adobe-courier-bold-o-normal--12-*-*-*-*-*-*

    I don't really know how to reproduce this, but I'll post
    whatever appears in my logs which might relate to this. I
    use 5.2 at home because it's declared stable, but I use
    5.3RC1 on another machine. I'll inform you if I'll ever get
    strange error messages.

     
  • Eddy De Greef
    Eddy De Greef
    2002-12-05

    • status: open --> closed
     
  • Eddy De Greef
    Eddy De Greef
    2002-12-05

    Logged In: YES
    user_id=73597

    Assuming it is solved in 5.3. Reopen if necessary.

     
  • Bert Wesarg
    Bert Wesarg
    2007-07-27

    Logged In: YES
    user_id=122956
    Originator: NO

    I advise to reopen this bug. follow these instruction with current CVS HEAD:

    start Nedit in a clear NEDIT_HOME:

    $ mkdir clear
    $ cd clear
    $ NEDIT_HOME=$PWD nedit -xrm 'nedit.autoScrollVPadding: 16'

    use a slightly larger nedit.autoScrollVPadding value as the default, but with the default the error triggers too

    now open a simple text file with at least 16 lines and resize the window to 15 lines and select 'Auto Scroll Near Window Top/Bottom' from the pref menu

    use page_down till the end of the file but press it afterwards a few times more and look

    Built on: Linux, 486, GNU C
    Built at: Jul 28 2007, 00:36:46
    With Motif: 2.2.3 [@(#)Motif Version 2.2.3]
    Running Motif: 2.2 [unknown]
    Server: The X.Org Foundation 70200000
    Visual: 16-bit TrueColor (ID 0x23, Default)
    Locale: en_US.UTF-8

     
  • Thorsten Haude
    Thorsten Haude
    2007-12-27

    • status: closed --> open
     
  • Thorsten Haude
    Thorsten Haude
    2007-12-27

    Logged In: YES
    user_id=119143
    Originator: NO

    Looks like NEdit has a déjà vu.

    Bert, did you notice any ill-effects?

     
  • Bert Wesarg
    Bert Wesarg
    2007-12-28

    Logged In: YES
    user_id=122956
    Originator: NO

    If you mean "data loss" by "ill-effects", than no.