On Tue, Jun 30, 2009 at 7:45 PM, Hin-Tak Leung <hintak_leung@yahoo.co.uk> wrote:

At least one of them isn't "syntax mistakes" - it is change needed due to changes introduced elsewhere in newer kernel. If I remember correctly, there were some mention of 1.55 being released for newer kernels a few weeks ago, for at least one if not both of the issues you reported. Thanks anyhow - but 1.55 or svn likely already fixes those?

 Yeah, as it turns out, the issue is already fixed in 1.55 :-)
 


--- On Tue, 30/6/09, Amod <amodjaltade@gmail.com> wrote:

> Under version 1.54
> There are 2 syntax mistakes on line number 1747 of the file
> drivers/wrapndis.c which lead to unsuccessful compilation
> on kernel >=2.6.29
>
> The following patch fixes the issue
>
> diff -Naur ndiswrapper-1.54/driver/wrapndis.c
> ndiswrapper-1.54.new/driver/wrapndis.c
>
> --- ndiswrapper-1.54/driver/wrapndis.c    2009-01-22
> 10:53:16.000000000 +0530
> +++ ndiswrapper-1.54.new/driver/wrapndis.c    2009-06-30
> 19:03:55.030684240 +0530
> @@ -1744,7 +1744,7 @@
>      .ndo_set_mac_address = ndis_set_mac_address,
>
>      .ndo_get_stats = ndis_get_stats,
>  #ifdef CONFIG_NET_POLL_CONTROLLER
> -    .poll_controller = ndis_poll_controller;
> +    .ndo_poll_controller = ndis_poll_controller
>  #endif
>  };
>  #endif
>
>
> Cheers !
>
> --Thank you !
>
>
> -----Inline Attachment Follows-----
>
> ------------------------------------------------------------------------------
>
> -----Inline Attachment Follows-----
>
> _______________________________________________
> Ndiswrapper-general mailing list
> Ndiswrapper-general@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/ndiswrapper-general
>







--
====================================
                       With Regards ,
                                            Amod
====================================