Paulo da Silva escreveu:
Pavel Roskin escreveu:
Hello!

On Sat, 2006-11-25 at 06:30 +0000, Paulo da Silva wrote:

  
The driver came in a CD from my ASUS wl-167g card.
    

I have found it on
http://support.asus.com/download/download.aspx?SLanguage=en-us

The actual driver is at
http://dlsvr01.asus.com/pub/ASUS/wireless/WL-167g/Driver_1110.zip

  
Anyway, from other messages in this list,
this seems to be a known case.

"The problem is ndiswrapper -i is not copying the .sys file to the
 appropriate subdirectory under /etc/ndiswrapper. When I copied it
 manually, everything was fine"
    

I cannot reproduce this problem with the svn version of ndiswrapper.  I
guess it was fixed.

  
I have searched for that driver. I found a linux native driver and played
a while with it but it froze my computer! Only forced reboots recover it.

I didn't go any further in search. Thanks for the link. May be this is
a new and improved version.

About svn version - (new 1.30?) I'll give it a try when it is in the
gentoo tree. In the meanwhile I am with 1.26. It works pretty fine.

If something went wrong, I'll came back.

I emerged the last version in the gentoo tree (1.33).
It successfully loaded the driver but it fails to communicate
with the router!
After iwconfig and ifconfig, a ping to the router fails. The led
of the adapter blinks when trying to ping the router.
I only could successfully get one connection imediately after
powering off/on the router.

1.26 still working fine. I emerged several times 1.26 and 1.33.
1.26 always worked. 1.33 only worked once as I said.

BTW, a coincidence or not, my USB mouse blocked once when
I was trying 1.33. I needed to remove the USB mouse adapter
and reinsert it again to have it back!
My USB mouse *never* stopped working before.

My current kernel: 2.6.19

...
Regards.
Paulo