I have a Dell TrueMobile 1300 in a Dell laptop which works quite well with ndiswrapper-1.1 if encryption is disabled. However, I've been unsuccessful with WPA (using  wpa_supplicant -0.3.8 ).  The AP  ( WRT54G with Firmware Version: v3.01.3 )  is configured for  WPA PSK TKIP and is never found.  

Over the last few days I've tried ndiswrapper-1.1 and ndiswrapper-1.1+CVS.Firmware Version: v3.01.3

System details and logs follow, any pointers or suggestions will be greatly appreciated.  Thanks.

-- Neville

#----------------------------------------

Linux Distribution:   SuSE-9.2
Kernel version:         2.6.8-24.13-default
Dell TrueMobile 1300 Adapter

"lspci -v"

0000:02:03.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)
        Subsystem: Dell TrueMobile 1300 WLAN Mini-PCI Card
        Flags: bus master, fast devsel, latency 32, IRQ 7
        Memory at f8ffc000 (32-bit, non-prefetchable)
        Capabilities: [40] Power Management version 2

#----------------------------------------

# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

irda0     no wireless extensions.

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 16, therefore some driver features
may not be available...

wlan0     IEEE 802.11g  ESSID:off/any
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:00:00:00:00:00
          Bit Rate:54 Mb/s   Tx-Power:25 dBm
          RTS thr:2347 B   Fragment thr:2346 B
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:32987   Missed beacon:0


#----------------------------------------
#
#/usr/local/src/wireless/wpa_supplicant-0.3.8/.config
#
CONFIG_WIRELESS_EXTENSION=y
CONFIG_DRIVER_NDISWRAPPER=y
CONFIG_CTRL_IFACE=y
CONFIG_EAP_PSK=y
#----------------------------------------

#
# /etc/wpa_supplicant.conf
#
# home network; allow all valid ciphers
#
# allow frontend (e.g., wpa_cli) to be used by all users in 'wheel' group
#

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=1

network={
        ssid="Test"
        scan_ssid=1
        key_mgmt=WPA-PSK
        psk="SomePassPhrase"
        pairwise=CCMP TKIP
        group=CCMP TKIP
        proto=WPA
}
#----------------------------------------

wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -d

Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'default'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0 (from group name 'wheel')
ap_scan=1
Priority group 0
   id=0 ssid='Test'
Initializing interface (2) 'wlan0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Own MAC address: 00:90:4b:24:85:91
Setting scan request: 0 sec 100000 usec
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=4):
     54 65 73 74                                       Test
ioctl[SIOCSIWSCAN{,EXT}]: No such device
Failed to initiate AP scan.
Setting scan request: 10 sec 0 usec
Scan timeout - try to get results
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 0
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 0
No suitable AP found.
Setting scan request: 5 sec 0 usec
Signal 2 received - terminating
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0


#----------------------------------------
#
# From 'dmesg'
#

ndiswrapper version 1.1+CVS loaded (preempt=no,smp=no)
ndiswrapper: driver bcmwl5 (Broadcom,06/25/2004, 3.40.73.0) loaded
ACPI: PCI interrupt 0000:02:03.0[A] -> GSI 7 (level, low) -> IRQ 7
ndiswrapper: using irq 7
wlan0: ndiswrapper ethernet device 00:90:4b:24:85:91 using driver bcmwl5, configuration file 14E4:4320.5.conf
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP
NET: Registered protocol family 17
wlan0: no IPv6 routers present

#----------------------------------------