Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Wireless Extension 18 ??

Help
spamnchips
2005-08-08
2012-10-06
  • spamnchips
    spamnchips
    2005-08-08

    I have successfully installed ndiswrapper v 1.2 into my SuSe 9.3 setup and setup my Belkin F5D7000 PCI card. wlan0 now exists and shows my card with encryption but will not link to my ESSID. Running iwconfig wlan0 scan gives ESSID as off/any but then prints this message.

    Warning: Driver for device wlan0 recommend version 18 of Wireless Extension, but has been compiled with version 17, therefore some driveer features may not be available.

    Can anybody translate this into something I can understand please and advise on what needs to be done.

    Thanx.

     
    • spamnchips
      spamnchips
      2005-08-10

      Thanks. I'll give it a try

       
    • lsproc
      lsproc
      2005-08-08

      Ive got the same bug in Ubuntu. Try this that I was reccomended.

      Install the driver
      Run ndiswrapper -m
      modprobe wlan0 (NOT NDISWRAPPER)

      I havent tested it but I presume you could use NDISWRAPPER for the modprobe. Alternativly if you have a wired LAN (most modern motherbords have it onboard) you can add this think that is kind of like a arial for it.

       
    • Matthew
      Matthew
      2005-08-08

      Basicly that message is just a warning you can ignore. It is saying that the driver wants Wireless Extension version 18 but it only got version 17. To you the end-user this means nothing and can be ignored. To get rid of the error message would require installing a beta version of wireless tools which i cannot recomend.

       
      • spamnchips
        spamnchips
        2005-08-10

        Thanks for the explanation