couldn't load driver netr7364

Help
roosh3
2010-06-30
2012-10-06
  • roosh3
    roosh3
    2010-06-30

    I'm trying to use ndiswrapper to use a windows driver (netr7364) on ubuntu
    10.04 64-bit for my ralink wireless adapter. I am using version 1.56 that I
    recently compiled. However, it fails to load, giving this message in syslog
    after starting it with "sudo modprobe ndiswrapper":

    Jun 24 17:58:47 roosh-desktop kernel: [  921.765989] ndiswrapper version 1.56 loaded (smp=yes, preempt=no)
    Jun 24 17:58:47 roosh-desktop kernel: [  921.910039] usb 1-7: reset high speed USB device using ehci_hcd and address 4
    Jun 24 17:58:47 roosh-desktop loadndisdriver: loadndisdriver: load_driver(358): couldn't load driver netr7364
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147400] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisMResetComplete'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147421] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisMIndicateStatusEx'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147437] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisMDeregisterMiniportDriver'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147452] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisMRegisterMiniportDriver'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147471] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisMSetMiniportAttributes'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147502] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisFreeNetBufferPool'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147516] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisAllocateMdl'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147569] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisFreeMdl'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147583] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisMSendNetBufferListsComplete'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147597] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisMIndicateReceiveNetBufferLists'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147618] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisOpenConfigurationEx'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147633] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferListPool'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147658] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisFreeNetBufferList'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147671] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisFreeNetBufferListPool'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147692] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisAllocateMemoryWithTagPriority'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147706] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferAndNetBufferList'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147721] ndiswrapper (import:233): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferPool'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147748] ndiswrapper (import:233): unknown symbol: WDFLDR.SYS:'WdfVersionUnbind'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147759] ndiswrapper (import:233): unknown symbol: WDFLDR.SYS:'WdfVersionBind'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.147764] ndiswrapper (load_sys_files:206): couldn't prepare driver 'netr7364'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.148722] ndiswrapper (load_wrap_driver:108): couldn't load driver netr7364; check system log for messages from 'loadndisdriver'
    Jun 24 17:58:47 roosh-desktop kernel: [  922.148807] usbcore: registered new interface driver ndiswrapper
    

    Any help?

     
  • Hi,
    looks like you're trying to load a vista or win7 driver (NDIS 6.x). Up to now
    ndiswrapper only supports Windows XP drivers (NDIS 5.x). So you have to look
    for a Windows XP 64 driver for your device.
    Eventually pgiri will add support for NDIS 6.x (at least I think so)

     
  • roosh3
    roosh3
    2010-07-01

    Thanks so much for your help.

    I found a XP 32-bit driver and it works on Ubuntu 32-bit Live-CD (my card is a
    Gemtek WUBR177G, the driver I found was rt73). It seems Ubuntu's driver does
    not do its job well.

    Anyways, I'm going to try to look for an XP 64 driver, or in worse case,
    install Ubuntu 32-bit.

    Again, thanks for your help. I've been trying to get this working for over a
    year!

     
  • roosh3
    roosh3
    2010-07-02

    Good News:
    I did finally get a 64 bit driver from the ralink website, as you mentioned. I
    had to install some sort of install-shield trial on my windows partition
    (cabextract and unshield didn't work) and extract the .cab .inf and . sys
    files for rt73 XP 64-bit.

     
  • roosh3
    roosh3
    2010-07-02

    Oh yea.
    Thanks all for your help. I have found this forum to be a lot more helpful
    than Ubuntu's :)

     
  • You're right:
    extracting the WinXP 64 driver from the Setup can be a hassle - especially if
    you don't have a WindowsXP 64 bit installation. And I know nobody who really
    posses WinXP 64.

     
  • roosh3
    roosh3
    2010-07-03

    also, "cabextract" and "unshield" didn't work on the .exe files from ralink.
    They did work on the ones from HP's website, though. I wonder why...