Broadcom 4311 (Dell 1390) mini-PCIe -- no joy

Help
Loïc
2007-02-14
2012-10-06
  • Loïc
    Loïc
    2007-02-14

    I have a problem to have my Dell Wireless 1390 to work.
    The computer is a Dell Inspiron 1501, Athlon64 dual core, right now with SMP and in 64 bit, but I've had problems with a lot of different configurations (32 and 64 bits, single core enabled as well as dual).

    The wifi card is a Broadcom 4311, connected to the motherboard through a mini-PCIe connector.

    Some relevant info:

    cognac % ndiswrapper -l
    bcmwl5 : driver installed
    device (14E4:4311) present (alternate driver: bcm43xx)
    cognac % ndiswrapper -v
    utils version: 1.9
    driver version: 1.37
    vermagic: 2.6.20 SMP mod_unload
    cognac % uname -a
    Linux cognac 2.6.20 #1 SMP Mon Feb 12 10:40:09 CET 2007 x86_64 GNU/Linux

    Description of the problems:
    iwconfig wlan0 essid "whatever" does not work at all.
    wpa_supplicant and WEP encryption have never worked.
    When autoloaded, the ESSID is changed to the SSID of some unencrypted wifi connection and the connection is ok. Precisely,

    • if I set my wireless router (ASUS WL-500g, broadcom 4320, wl500g.info custom firmware) to be unencrypted, I cannot connect to it.
    • One of my neighbour has (sometimes) an unencrypted wireless connection open and the card will connect to it.
    • I know one place where there is an unencrypted connection and the card connect to it.
    • For the connection to happen I need to do the following: 1) modprobe ndiswrapper (no connection, ifplugd is started). 2) rmmod ndiswrapper; then ndiswrapper is autoloaded (because of ifplugd) and connects to some (but not all) unencryped connections. If I try to manually change the essid, the connection drops.

    It looks weird to me.

    I've tried to enable DEBUG* messages, but I don't manage to understand anything.

    Do you have any idea ?

    Thank you,

    Loïc

     
    • Read FAQ in wiki about not being able to set ssid (especially WEP encryption). Follow up with giving details (scan results, how you set ssid, 'dmesg' output and so on).