kernel panic on amd64 and strange fix

Help
2005-02-12
2012-10-06
  • KnusperKeks
    KnusperKeks
    2005-02-12

    System

    Acerferrari 3200

    $ uname -a

    Linux kruemel 2.6.10-gentoo-r7 #10 Fri Feb 11 20:35:50 GMT 2005 x86_64 Mobile AMD Athlon 64 Processor 2800+ AuthenticAMD GNU/Linux

    $lspci -v
    0000:00:09.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
    Subsystem: Wistron NeWeb Corp.: Unknown device 1220
    Flags: bus master, fast devsel, latency 64, IRQ 19
    Memory at d0014000 (32-bit, non-prefetchable)

    ndiswrapper version : CVS
    ndiswrapper version 1.1rc1 loaded (preempt=no,smp=no)

    the Problem :
    system crashs after loading the ndiswrapper module.

    the fix:
    after some testing i discovered that it works
    with the following kernel settings enabled:

    [*] Kernel debugging
    [ ] Magic SysRq key
    [ ] Collect scheduler statistics
    [*] Debug memory allocations
    [ ] Spinlock debugging
    [*] Sleep-inside-spinlock checking
    [*] kobject debugging

    now im able to load the driver without any crash,
    but it crashs if i turn the radiobutton off and
    unload ndiswrapper.

     
    • Ron
      Ron
      2005-02-21

      I'm also having this mystery crash, I'm going to recommpile my kernel with you parameters and see if that helps

       
    • KnusperKeks
      KnusperKeks
      2005-02-23

      with the latest cvs-version the driver wont crash if i turn the radiobutton off and unload the driver.

      the driver works well but there are still some problems.

      1. crash without the settings off the first post (tested with
        the latstet cvs some minutes ago )

      2. setting the a key will not work everytime.
        u have to load and unload the module several times.

       
    • Ron
      Ron
      2005-02-23

      Quote: with the latest cvs-version the driver wont crash if i turn the radiobutton off and unload the driver.

      I'm assuming your using a graphical utility to work the driver? I'm using command line iwconfg. However your fix is working for me :)

       
    • KnusperKeks
      KnusperKeks
      2005-02-27

      no its a real hardware button on the notebook :)
      im using the wirelesstoolz ( iwconfig & co ) like u.

       
    • Kernel freeze here,Intel PIII Coppermine, kernel 2.6.10Y ndisw 1.1rc3. Not possible to trace anything the system freezes hard and crule, no mercy what so ever..

       
    • KnusperKeks
      KnusperKeks
      2005-03-03

      ok latest cvs fix the main problem but maybe
      opend a new one... ( wait what pgiri says to the last post on the bug report)

      see bug : 1149515

       
    • KnusperKeks
      KnusperKeks
      2005-03-03

      [SOLVED]

      ok checked the cvs version the bug is fixed
      thx to pgiri