Problems with sis163u Vista64bit-Drivers

Help
2007-03-08
2012-10-06
  • Julian Pietron
    Julian Pietron
    2007-03-08

    Hi,

    I'm having big trouble with sis163u 64bit-Drivers. These drivers are only for Windows Vista 64bit and do not work on lower versions (e.g. XP Professional 64bit). And it seems as if they wouldn't work in ndiswrapper, too. While the driver is installed without errors, some problems occur when modprobe'ing:

    ndiswrapper version 1.38 loaded (preempt=yes,smp=yes)
    usb 1-3: reset high speed USB device using ehci_hcd and address 2
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisMSendNetBufferListsComplete'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisAllocateFragmentNetBufferList'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisFreeFragmentNetBufferList'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisRetreatNetBufferDataStart'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisAdvanceNetBufferDataStart'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferListPool'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisFreeMdl'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisAllocateMdl'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferPool'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisAllocateNetBuffer'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisFreeNetBufferListPool'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisFreeNetBufferList'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisFreeNetBuffer'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferList'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisMDeregisterMiniportDriver'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisMRegisterMiniportDriver'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisMOidRequestComplete'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisMResetComplete'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisMSetMiniportAttributes'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisMIndicateReceiveNetBufferLists'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisMIndicateStatusEx'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisOpenConfigurationEx'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisFreeNetBufferPool'
    ndiswrapper (import:245): unknown symbol: NDIS.SYS:'NdisAllocateMemoryWithTagPriority'
    ndiswrapper (load_sys_files:216): couldn't prepare driver 'sis163u'
    ndiswrapper (load_wrap_driver:118): couldn't load driver sis163u; check system log for messages from 'loadndisdriver'
    usbcore: registered new interface driver ndiswrapper

    So there seem to be some new functions in Vista's NDIS ndiswrapper doesn't support yet.

    Thanks for help,
    jupi

     
    • I don't need register contents, but stack trace would be useful. Even better would be debug trace with 'DEBUG=3' (see wiki enrty Bugs).

       
    • Vista drivers are not supported. You need to use drivers for XP with ndiswrapper.

       
    • Also, give link to where you got the Vista drivers for sis163u (32-bit). That may help in adding support for Vista.

       
    • Julian Pietron
      Julian Pietron
      2007-03-09

      The Vista and Vista64 drivers are available here: http://support.fujitsu-siemens.de/download/ShowDescription.asp?SoftwareGUID=A172B7BC-5140-441B-97D0-85C336545CC6&ClassID=2F4450CB-AECD-4376-9C13-09176B437989

      (they are for FSCs Amilo Pa 1538 WLAN which uses a SiS163u chip)

       
    • Jerome Esteves
      Jerome Esteves
      2007-04-19

      On AMD64 + Etch (debian 4.0)

      I saw you had a problem with your FSCs Amilo Pa 1538 with
      your WLAN, I Have the same Notebook and I would like to know
      if you resolved your problem.
      I also tried the vista64 driver with ndiswrapper (latest and from Etch Debian) but i had
      the same problem. I tried also the drivers from sis, "xp OS"where the is a amd64 directory, This driver loads better and I'm abble to make a :
      iwlist wlan1 scan

      (and have the network found)

      but then I have a lot of kernel errors comming from ndiswrapper, and the system freezes.

      • The ndiswrapper from Etch original kernel (i don't know the version)
        tells repetidly.
        BUG .... It seems on an timer timeout and scheduling and then I have the stack displayed with some ndis ... wait_for_infos.

      • The ndiswrapper from yesterday(19 April 2007) (CVS) 1.42 :
        Does not release modprobe. It hangs on setting a kthead_priority. with a oops. And I have the registers displayed.

      I'm sorry not to put the full error message, if you are interested I can copy it by hand.

      Best Regards

      Jerome Esteves