ndiswrapper and Sinus 154 Wlan Stick suse10.0

Help
2007-04-25
2012-10-06
  • Hello,

    i've got an problem with an USB Wlan Stick Sinus 154 from T-online. I think it got an Prism2 Chip.

    I've installed ndiswrapper in Version 1.42 on an Kernel 2.6.13-15 on an Suse 10.0 IBM Laptop.

    Then i've installed the Windows Driver and the command ndiswrapper -l gives me the folloing output:

    prisma02 : driver installed
    device (0915:2000) present

    When i tried to configure the Wireless Device in YAST, i've choosen the ndiswrapper modul und when i click on finish, the LED is blinking for a little while and then it is dark again, and kwifimanager says the Device is Disabled.

    ifconfig gives following output (after i droped the command "ifconfig wlan0 up"):

    linux:/etc/sysconfig/network # ifconfig
    eth0 Protokoll:Ethernet Hardware Adresse 00:03:47:8B:CD:AF
    inet Adresse:192.168.2.10 Bcast:192.168.2.255 Maske:255.255.255.0
    inet6 Adresse: fe80::203:47ff:fe8b:cdaf/64 Gültigkeitsbereich:Verbindung
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:13978 errors:0 dropped:0 overruns:0 frame:0
    TX packets:14585 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:8122655 (7.7 Mb) TX bytes:2703623 (2.5 Mb)
    Interrupt:11

    lo Protokoll:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:594 errors:0 dropped:0 overruns:0 frame:0
    TX packets:594 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:0
    RX bytes:47914 (46.7 Kb) TX bytes:47914 (46.7 Kb)

    wlan0 Protokoll:Ethernet Hardware Adresse 00:03:C9:A9:4C:E7
    inet6 Adresse: fe80::203:c9ff:fea9:4ce7/64 Gültigkeitsbereich:Verbindung
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 Sendewarteschlangenlänge:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    And an rcnetwork restart gives me following output:

    linux:/etc/sysconfig/network # rcnetwork restart
    Shutting down network interfaces:
    eth0 device: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 0c)
    eth0 configuration: eth-id-00:03:47:8b:cd:af done
    wlan0 done
    Shutting down service network . . . . . . . . . . . . . done
    Hint: you may set mandatory devices in /etc/sysconfig/network/config
    Setting up network interfaces:
    lo
    lo IP address: 127.0.0.1/8 done
    eth0 device: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 0c)
    eth0 configuration: eth-id-00:03:47:8b:cd:af
    eth0 IP address: 192.168.2.10/24 done
    wlan0
    ifup-wireless: command 'iwconfig wlan0 mode Managed' returned
    ifup-wireless: Error for wireless request "Set Mode" (8B06) :
    ifup-wireless: SET failed on device wlan0 ; Invalid argument.
    ifup-wireless: command 'iwconfig wlan0 nick linux' returned
    ifup-wireless: Error for wireless request "Set Nickname" (8B1C) :
    ifup-wireless: SET failed on device wlan0 ; Invalid argument.
    ifup-wireless: command 'iwconfig wlan0 key off' returned
    ifup-wireless: Error for wireless request "Set Encode" (8B2A) :
    ifup-wireless: SET failed on device wlan0 ; Invalid argument.
    ifup-wireless: command 'iwconfig wlan0 key open 3333343337' returned
    ifup-wireless: Error for wireless request "Set Encode" (8B2A) :
    ifup-wireless: SET failed on device wlan0 ; Invalid argument.
    ifup-wireless: command 'iwconfig wlan0 essid WLAN' returned
    ifup-wireless: Error for wireless request "Set ESSID" (8B1A) :
    ifup-wireless: SET failed on device wlan0 ; Invalid argument. done
    modem0
    modem0 Startmode is 'manual' skipped
    Setting up service network . . . . . . . . . . . . . . done
    SuSEfirewall2: Warning: ip6tables does not support state matching. Extended IPv6 support disabled.
    SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    SuSEfirewall2: Warning: FW_ALLOW_INCOMING_HIGHPORTS_UDP is deprecated and will likely be removed in the future.
    SuSEfirewall2: Warning: If you think it should be kept please report your use case at
    SuSEfirewall2: Warning: http://forge.novell.com/modules/xfmod/project/?susefirewall2
    SuSEfirewall2: batch committing...
    SuSEfirewall2: Firewall rules successfully set

    I hope someone can give me an Hint about what is going wrong.

    Greetings

    smaragdestes