ubuntu 10.04 tew-424ub system hangs

Help
xzerth
2010-10-22
2012-10-06
  • xzerth
    xzerth
    2010-10-22

    Hi. I'm trying to get a Trendnet TEW-424UB wireless adapter to work on my
    laptop. I installed ndiswrapper (different versions tried) and the Windows
    driver (XP, 2000 etc) then I checked ndiswrapper -l and the driver is
    installed. The device is visible with the lsusb command. The problem I have is
    when I run "sudo modprobe ndiswrapper", the system hangs. When I do this, the
    light on the adapter comes on, but the system immediately hangs. On hard
    reboot, the device light does not come on and it does not load in network
    manager. I can't sniff any information from log.
    Kernel: 2.6.32-25-generic

     
  • If you're using a 64bit Kernel, chances are, that it's this bug:

    http://sourceforge.net/tracker/?func=detail&aid=2948988&group_id=93482&atid=6
    04452

    This is fixed in the trunk version, so you could try the trunk and see, if
    this helps (we should create a new 1.57 version in the near future)

    If you're using a 32bit Kernel or have already tried the trunk, then we really
    need the oops message. Maybe you can see some information, if you do something
    like

    sleep 5;sudo modprobe ndiswrapper
    

    and switch to the message screen (Ctrl-F10 on SuSE Linux - I don't know, if
    it's the same on ubuntu), before the oops kicks in.

     
  • xzerth
    xzerth
    2010-10-24

    Thank you for the reply! I'm using 32bit kernel and there aren't any oops
    information in the logs. Some information i managed to find in
    /var/log/messages but it seems to be ok. Ndiswrapper normally loads windows
    driver sis163u and it initializes TEW-424UB without any errors. (Can't paste
    exact log because I see it only when oops happened) There is no information in
    dmesg. Are there any other solutions?

     
  • xzerth
    xzerth
    2010-10-25

    Well, I.ve switched to maverick ubuntu which ships with 2.6.35-22 kernel. The
    problem still exists.