Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Why is ncks breaking with this OPeNDAP URL?

2012-11-19
2013-10-17
  • Latest and Greatest:  Netcdf 4.2.1.1 / NCO 4.2.2
    $ /usr/local/nco-4.2.2/bin/ncks -O -d time,0 -v nv,zeta http://testbedapps-dev.sura.org/thredds/dodsC/auto/in.usf.fvcom.ike.ultralite.vardrag.nowave.2d nathan.nc
    syntax error, unexpected WORD_STRING, expecting WORD_WORD
    context: Error { code = 500; message = "Variable name (h) must be unique within Group "^;};
    nco_err_exit(): ERROR Short NCO-generated message (usually name of function that triggered error): nco_get_vara()
    nco_err_exit(): ERROR Error code is -73. Translation into English with nc_strerror(-73) is "NetCDF: Malformed or inaccessible DAP DATADDS"
    nco_err_exit(): ERROR NCO will now exit with system call exit(EXIT_FAILURE)
    
     
  • Charlie Zender
    Charlie Zender
    2012-11-20

    Latest NCO is 4.2.3 but it doesn't make a difference. I get the same error as you. The DAP error message seems to be saying that DAP finds two objects both named "h" in the same group in the input file. Never seen that one before. Head scratcher. Suggest you obtain the file by other means and do forensics.
    cz

     
  • Charlie,
    Head scratcher for sure.   I tried accessing the exact same dataset via OPeNDAP using NetCDF4-Python and it worked fine.  I can't see anything in the OPeNDAP dataset access form that looks strange, can you?  The variable "h" looks fine:
    http://testbedapps-dev.sura.org/thredds/dodsC/auto/in.usf.fvcom.ike.ultralite.vardrag.nowave.2d.html

    Is there any way to drill deeper to figure out exactly what is going wrong in ncks?

    Thanks,
    Rich

     
  • Charlie,
    DOH!   I never thought to check NCDUMP.   Sorry for barking up the wrong tree.   I'll bark up Unidata's tree now.    There are several other dogs barking also, but I'll give it 110%.  ;-)

    -Rich