#14 MSI Task - Object reference not set to an instance of an obj

closed
nobody
None
1
2004-12-20
2004-12-20
davidsp8
No

Trying to build an MSI File and I keep getting "Object
reference not set to an instance of an object".

Build Script:

<target name="buildMsi" description="Build MSI">
<msi output="${outdir}\deploy\Setup.msi"
sourcedir="${outdir}\deploy\WebSite"
template="C:\Nant\nightly\bin\MSITaskTemplateVS.msi"
verbose="true">
<properties>
<property name="ProductCode" value="{7521DBD5-8039-
4686-800C-4644EE2ADEBA}" />
<property name="PackageCode" value="{96D8AA97-
72FB-48DB-80AE-CD1212B0A3E2}" />
<property name="ProductLanguage" value="1033" />
<property name="ProductName" value="Example" />
<property name="UpgradeCode" value="{E0FA6633-
7502-42E9-B3E0-EFF8026027CC}" />
<property name="ARPCONTACT" value="Example" />
<property name="Manufacturer" value="Example" />
<property name="ProductVersion" value="1.0.0" />
</properties>
<directories>
<directory name="D_BINDIR" foldername="bin"
root="TARGETDIR" />
</directories>
<components>
<component name="Content" id="{16B2FCA9-FD2D-
41b3-A7C9-068CAF9A70AB}" directory="TARGETDIR"
feature="DefaultFeature" attr="2">
<key file="${outdir}\deploy\WebSite\global.asax" />
<fileset basedir="${outdir}\deploy\WebSite">
<include name="global.asax" />
</fileset>
</component>
</components>
</msi>
</target>

Any ideas what may be causing this?

Discussion

  • James Geurts
    James Geurts
    2004-12-20

    Logged In: YES
    user_id=473974

    This is a usage question and does not belong here... I
    replied in the list. For a quick, short answer, The most
    noticable problems with the script were a problem with how
    the key file was specified and there was no features element.

     
  • James Geurts
    James Geurts
    2004-12-20

    • priority: 5 --> 1
    • status: open --> closed