Tree [400505] master /
History



File Date Author Commit
apport 2011-02-16 Vlad Vlad [2f0b56] .
hostings 2012-03-13 Влад Влад [d1d100] Added API Key for ImageShack uploads
icons 2010-10-29 Vlad Vlad [1e0ba2] v0.2.6
lib 2012-02-21 Влад Влад [11f2a6] Fix 100% cpu usage after generating screenshots...
locale-src 2011-01-08 Vlad Vlad [abbb8b] translations
man 2010-09-16 Vlad Vlad [9e3cd6] configure & install impr.
COPYING 2010-09-14 Vlad Vlad [99be18] inital
Nanoshot 2012-03-13 Влад Влад [400505] "Choose hosting" window is collapsed by default...
README 2010-09-24 Vlad Vlad [bd1684] check for PIL
configure 2010-12-06 Vlad Vlad [becf88] added more languages
configure.ac 2010-12-06 Vlad Vlad [becf88] added more languages
install.in 2011-06-10 Vlad Vlad [36f3d0] Improvements in installation scripts
setup.py 2011-06-10 Vlad Vlad [36f3d0] Improvements in installation scripts

Read Me

1. REQUIREMENTS

To run the program, you must have all of the following:

	* python-gtk2 (pygtk)
	* python-wnck
	* python-appindicator >= 0.2.2
	* python-cairo
	* python-dbus
	* python-pycurl (pycurl)

also recommended to install

	* gnome-screenshot (or Ksnapshot for KDE)
	* python-gnome2
	* python-gconf
	* python-gst (pygst)
	* python-imaging (Python Imaging Library (PIL))
	* MPlayer

Note that the version of python-appindicator must be greater than 0.2.2. Nanoshot also works with earlier versions, but the list of running windows are not updated dynamically (see bug https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/558841).

2. INSTALLATION

To install the program, enter the following commands:

	./configure
	./install

Then, if you want to uninstall the program, enter:

	./install uninstall