Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#3 Nagiosweb support on Mac os x

closed
nobody
None
5
2006-04-12
2006-04-10
vara
No

Hi,
I am working on Mac os x 10.4 and instllaed nagios and nagiosweb.
Nagios works fine but nagiosweb installation not working most of the
links.
After installation nagiosweb I am able to view side links for Hosts,
services and etc. links. When I go for adding new host, it does nothing
and I am not finding any submitton button any window.
Can I know the what may be the problem.
I am using Safari browser on Mac os x 10.4. Is this nagiosweb supports
on Safari browser?

Thanks,
Vara.

Discussion

  • Josh Konkol
    Josh Konkol
    2006-04-12

    Logged In: YES
    user_id=561514

    I'm going to have to defer to the community on this one. I
    don't have access to Safari on Mac to even test.

    Josh

     
  • Josh Konkol
    Josh Konkol
    2006-04-12

    • status: open --> closed
     
  • vara
    vara
    2006-04-13

    Logged In: YES
    user_id=1499085

    Yes, now I am able to add host, service and other things.
    Now only problem is if I click on "Restart Process" button under "write config"
    show the cmd.cgi binary code on the web html output. It is not executing
    cmd.cgi from runscript.php.

    part of runscript.php is
    -----------------
    switch($action) {
    case 'restartprocess':
    header("Location:cgi-bin/cmd.cgi?cmd_typ=13&cmd_mod=2");
    break;
    }

    Is this correct syntax to execute cmd.cgi from php?.

    Please can you help me to resolve this issue.

    Thanks,
    Vara.

     
  • vara
    vara
    2006-04-13

    Logged In: YES
    user_id=1499085

    Typo error in previous comment:
    if I click on "Restart Process" button under "write config", it shows the output as
    content of cmd.cgi binary file.