#514 Confirm licensing of nagios-plugins

release-1.4.15
closed-fixed
Holger Weiß
None
5
2012-06-27
2011-06-02
Lars Vogdt
No

The COPYING file inside the tarball declares the package to be GPLv2+. However, the entire gl/ subdirectory is GPLv3+ and seems to be kept in sync with gnulib upstream (also GPLv3).

The statement on the nagios-plugins website does not help:

"The Nagios Plugins is currently distributed using the GNU General Public License version 2.

There is a task to convert the project to be under GPLv3. This is because some C code that we depend upon, from the GNUlib project, is under GPLv3 and therefore some of our C plugins also need to be GPLv3.

So the team has decided rather than having a mixed license, we'll distribute the core Nagios Plugins code as GPLv3.

This page will be updated when this has been completed."
Posted by tonvoon on 25 January 2008

Looks like there is no update, but the license questions is important for distributions like Debian, Fedora and openSUSE to include it. So can you please clarify the license status?

Discussion

  • Holger Weiß
    Holger Weiß
    2012-06-27

    The COPYING file has been updated to the GPLv3, so this issue will be solved with the upcoming 1.4.16 release. Thank you for your report.

     
  • Holger Weiß
    Holger Weiß
    2012-06-27

    • assigned_to: nobody --> hweiss
    • status: open --> closed-fixed