Show Waiting Links SQL Warning

Help
C
2007-03-17
2013-04-22
  • C
    C
    2007-03-17

    Greetings,

    I'm running MyThreads-Links v1.1.2 and I'm having an issue with "Show Waiting Links."

    . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
    The following 4 warnings are repeated 15 times. Probably for each of the 15 waiting links.

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/content/c/v/i/cvibes/html/links/mythreads/lib/lib_admin.php3 on line 470

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/content/c/v/i/cvibes/html/links/mythreads/lib/lib_admin.php3 on line 29

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/content/c/v/i/cvibes/html/links/mythreads/lib/lib_admin.php3 on line 474

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/content/c/v/i/cvibes/html/links/mythreads/lib/lib_admin.php3 on line 495

    . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

    After the warnings, the usual "Admin Mode: Logged In" text is displayed, except that now the "Category" selector field is empty, and "Submitters IP and Email" are blank.

    I haven't modified any of the code since I upgraded to MyThreads-Links v1.1.2 last year.
    I've been able to use "Show Waiting Links" without a problem until a few days ago.

    Between 3/11/2007 and 3/15/2007, 11 links were added by different users at beglobal.biz.

    I looked at the new records in 'my_wait' and 'my_links' and they seem okay.

    I haven't tried deleting those 11 links using MyThreads because of the warnings.

    I've uploaded MyThreads again just in case the code of my Web server had been modified or become corrupt. But no change.

    Otherwise, MyThreads appears to be operating normally.

    Does MyThreads have a problem handling 15 or more waiting links?
    Could there be a some code that was entered into the fields that's causing problems?
    Any suggestions on what the problem may be and how to resolve it?

    RootsMan
    http://CVibes.net/
    .

     
    • C
      C
      2007-03-17

      Greetings,

      After backing up my database, I deleted one of the new records from my_links and my_wait, (Same idx). So now there are 14 waiting links.

      Now, Show Waiting Links is displaying correctly.

      One additional thing. Show Waiting Links is taking a longer time than usual, about a minute, to return results.

      Maybe the warnings I received were a timing issue? Or is 15 waiting links and issue?

      RootsMan
      http://CVibes.net/
      .

       
      • Ludovic Drolez
        Ludovic Drolez
        2007-03-17

        No problems, you can have hundreds of waiting links.
        If you have a 1 minute delay, maybe it's because you have "no_url_check" => 0 in config.php3 ?

         
    • C
      C
      2007-03-17

      Yes, "no_url_check" => 0.
      I set "no_url_check" => 1 and it is much faster now. Although it used to be okay before.

      For the record I manually deleted, the 'message' field contained two instances of & .
      Is it that MySQL had trouble parsing the & since they were not escaped?