Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Myster sais: Could not connect on Local socke

Help
2009-08-18
2013-04-09
  • nichtleiter
    nichtleiter
    2009-08-18

    Hi,

    I wanted to give Myster a try, but it doesn't even start!? The last three lines Myster puts out are

    MAIN THREAD: Starting loader Thread..
    Could not connect on Local socket..
    Close all open Myster versions or just restart.. that should work

    Is there a chance to solve this problem?

    Thanks for your effort and with best regards

    J.D.

    PS: Yes, i have restarted Myster and get the same error ;)

     
  • Andrew Trumper
    Andrew Trumper
    2010-02-08

    Yeah, sorry about that error message it's not particularly enlightening.  If I were to re-write it now it would be something like:

    "There seems to be another copy of Myster already running but Myster couldn't contact it. If you're sharing the computer with other people, one of them might be running Myster already or it might be that that Myster was not started from the same place the previous copy was started. Restarting the computer will make sure that the other Myster client gets quit."

    In order to stop multiple instances of Myster from running at the same time, Myster will try and open a server listening on port 10457. That failed. Typically when this happens it means there's already an instance of Myster running. Myster tried to contact the running instance using information in a file called ".lockFile" in the directory that it was run from. If that file isn't there or contacting the current running instance fails, Myster doesn't start.

    In testing this situation happened on MacOS X in certain circumstances when Myster crashed. For whatever reason, MacsOS X didn't free up the TCP/IP server port. Restarting the machine resets the port and Myster could run again.

     
  • Nick Golden
    Nick Golden
    2010-10-31

    Any news about this problem?

     
  • Andrew Trumper
    Andrew Trumper
    2010-11-06

    Maybe the local firewall software is stopping myster from creating a server socket on port 10457? Or perhaps there's some sort of permissions issue? Is this happening on the MacOS, windows or Linux? What version?