#14 not able to install database driver

MySQLdb
closed
Andy Dustman
MySQLdb (53)
5
2012-09-19
2004-02-20
vaibhav
No

hi,
i am using zope(2.6.4) and mySQL database(3.23.39)
on red hat linux8.0.
I am using ZMySQLDA 2.0.7 and Mysql-python 9.0.2 as
database adapters and database driver.
i have successfully installed the database adapter(it's
available in the drop down menu of Zope).

In order to install the database driver i have downloaded
the development header and library files for mySQL
(MySQL-devel-3.23.36-1.LS1.i386.rpm), python(python2-
devel-2.2.2-11.7.3.i386.rpm) and zlib(zlib-devel-1.1.4-
8.8x.i386.rpm) .i have installed the mysql-devel package
but when i try to install the
python2-devel-2.2.2-11.7.3.i386.rpm package i get the
following error message

s@linux01 ~/ZOPE]$ rpm -i --test python2-devel-2.2.2-
11.7.3.i386.rpm
error: failed dependencies:
rpmlib(PayloadFilesHavePrefix) <= 4.0-1 is needed
by python2-devel-2.2.2-11.7.3
rpmlib(CompressedFileNames) <= 3.0.4-1 is needed
by python2-devel-2.2.2-11.7.3

is this due to version incompatability or some other
reason. please help me to fix this error.

thanks in advance

vaibhav

Discussion

  • Andy Dustman
    Andy Dustman
    2004-05-16

    Logged In: YES
    user_id=71372

    This is not a patch