Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#11 Java class loader failure

open
nobody
Other (4)
5
2012-12-31
2012-10-18
Maria
No

I would love to try this out, but it fails with the following error - is there a specific jdk you need to run this?

D:\DO_NOT_DELETE>cd MyPasswords_2_92

D:\DO_NOT_DELETE\MyPasswords_2_92>MyPasswords.bat

D:\DO_NOT_DELETE\MyPasswords_2_92>java -jar MyPasswords.jar
Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version n
umber in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:12
4)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

maria.olivero@charter.net

Discussion

  • Hi,

    What JRE version are you using?

    MyPasswords 2.9+ needs Java 7.