Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#955 Mumble does not re-connect after suspend

open
Mumble (514)
5
2012-10-30
2011-09-08
crazedfred
No

On Windows 7 with Mumble client 1.2.3, Mumble does not automatically re-connect after the computer is put into sleep or hibernate mode. It is a desktop machine, so it is (essentially) never without internet, however every time I resume from sleep Mumble says a single line:

[6:37:29 AM] Server connection failed: The remote host closed the connection.

And stops trying. This is irritating, as every time I suspend my PC I have to Server --> Connect --> Connect. My expected behavior in this scenario would be Mumble's ordinary behavior on disconnect: auto-retry until canceled or success.

Discussion

  • Avinash Arora
    Avinash Arora
    2011-09-29

    Do you have auto connect set up?

    I don't have the issue you are describing and my laptop I literally just close and reopen at will, and it always reconnects after one or two quick fails.

     
  • fwaggle
    fwaggle
    2011-09-29

    I just tried, and I can reproduce this. Windows 7 x64 desktop - pretty sure it went to hibernate, not sleep because of all the disk activity before it shut down. Start it back up, and Mumble didn't reconnect.

    I'll talk to the devs and find out if it's expected behavior or not.

    @bleedscarlet: What OS/arch/etc are you on, and what is the setting for your laptop to do when the lid is closed (sleep, hibernate, etc)?

     
  • crazedfred
    crazedfred
    2011-09-29

     
  • crazedfred
    crazedfred
    2011-09-29

    Yes, I have the "Reconnect automatically" option enabled. I do not have the "Recconect to last server on startup" option enabled, however I assume this does not apply since Mumble is never closed.

    fawggle: you can tell if a Windows machine hibernates or sleeps by going to the start menu and looking at the right-hand menu; the > arrow expands a list of shutdown, restart, etc.

    I just tested and reproduced the issue on Windows 7 x64 desktop (wired internet). After a sleep-and-resume cycle, Pandora immediately resumed, internet worked fine, but Mumble remains disconnected. Attached is a screenshot of what the UI looks like. At this step, if I go Server --> Connect and choose a server, it connects just fine.

     
  • crazedfred
    crazedfred
    2011-09-29

     
  • fwaggle
    fwaggle
    2011-09-29

    Okay apparently mine is sleeping then - I figured it was hibernate because of all the disk activity. Anyway, I can reproduce this so I'll see if I can figure out why it's doing it after I figure out whether or not it's desired behavior or not (I can't fathom why it would be, but I've already "fixed" one not-really-a bug today).