Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

defaultchannel and rememberchannel not working

Help
ScottyG
2014-01-09
2014-01-09
  • ScottyG
    ScottyG
    2014-01-09

    Hi,

    In my mumble-server.ini file, I've set defaultchannel=4 (my AFK channel) and rememberchannel=false.
    When a user connects to my server, they are placed in the same channel they were in when they disconnected.
    Any ideas to why these commands isn't working as intended?

    Thanks in advance.

     
  • Natenom
    Natenom
    2014-01-09

    • If you add new variables to your .ini file they must be placed before the [Ice] section.
    • Did you restart your server after the change?
    • Check if the key rememberchannel is set in your database, which would override settings from your .ini file.
     
    • ScottyG
      ScottyG
      2014-01-09

      I have the [Ice] section at the end of my .ini file and the commands before it.
      The server has been closed down and started up again with: sudo dpkg-reconfigure mumble-server
      Under which table should the this setting be? Am using SQLite Database Browser to check but doesn't seem to be there anywhere.

       
  • Natenom
    Natenom
    2014-01-09

    Should be in "config".

     
    • ScottyG
      ScottyG
      2014-01-09

      In "config" I only have 2 keys and none of them is rememberchannel.
      I have "certificate" and "key" in that table only.

      In my .ini file, I placed the commands right under "welcometext" and right before "port". Should I try and move it higher up?

       
  • Natenom
    Natenom
    2014-01-09

    Could something be wrong with your var welcomemessage so that murmur misses rememberchannel? If not the position is not relevant.

     
    • ScottyG
      ScottyG
      2014-01-09

      Just tried moving it above "welcometext" and it's still the same.
      Can I set these 2 commands in the database instead? Perhaps that could solve it if it overwrites the .ini file.

       
  • Natenom
    Natenom
    2014-01-09

    Yes, that should work.

    Ah ... missed that ... iirc dpkg-reconfigure does not restart the server, does it?

    Instead do a "sudo service mumble-server restart".

     
    • ScottyG
      ScottyG
      2014-01-09

      No it doesn't. I normally stop the server through htop and start it again with that command.
      Will try and add the commands under "config" and see if that works.

       
    • ScottyG
      ScottyG
      2014-01-09

      This is so strange.
      It still doesn't place the newly connected users in the defaultchannel. :s