Registration failed

Help
2009-12-17
2013-12-07
  • Im having trouble getting my mumble server to show in the server browser, i
    had my server showing up in the beta builds, but since updating to 1.2.0
    stable i get the following in my log file on startup:

    <W>2009-12-17 15:05:49.987 DBus registration succeeded

    <W>2009-12-17 15:05:49.987 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 21001"
    running

    <W>2009-12-17 15:05:49.987 Murmur 1.2.1 (718da1) running on Win: 5.2.3790.0:
    Booting servers

    Then after the server is online for a while i see this:

    <W>2009-12-17 16:10:19.596 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted

    <W>2009-12-17 16:10:19.674 1 => Registration failed: HTTP request failed

    Im using the same ini file i was using in the beta build, server has no
    serverpassword set ect.

    Using murmur on windows 2003 and can connect via adding the IP as a favourite.

    What might be the cause, or what can i try to correct this?

     
  • Dirk Krüger
    Dirk Krüger
    2009-12-17

    Hi,

    the line in my log file looks like this:

    <W>2009-12-07 15:18:27.134 Initializing settings from /etc/mumble-server.ini
    (basepath /etc)
    <W>2009-12-07 15:18:28.012 SSL: Added CA certificates from '/etc/ssl/certs/ca-
    certificates.crt'
    <W>2009-12-07 15:18:28.792 ServerDB: Openend SQLite database /var/lib/mumble-
    server/murmur.sqlite
    <W>2009-12-07 15:18:29.280 Failed to connect to D-Bus session
    <W>2009-12-07 15:18:30.139 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502"
    running
    <W>2009-12-07 15:18:30.650 Murmur 1.2.0 (1.2.0~beta2-1~ppa1~karmic1) running
    on X11: Ubuntu 9.10: Boot
    ing servers
    <W>2009-12-07 15:18:31.089 1 => Server listening on :64738
    <W>2009-12-07 15:18:31.205 1 => Announcing server via bonjour
    <W>2009-12-07 15:20:04.821 1 => <1:(-1)> New connection: 128.39.114.1:37597
    <W>2009-12-07 15:20:04.997 1 => <1:(-1)> Connection closed: The remote host
    closed the connection
    <W>2009-12-07 15:20:05.006 1 => Registration: Registration updated

    ater 1.2.0 got final have you set up your server from scratch?
    Maybe the Server certificate is not the same as the old one.
    Are you shure the

    registerPassword=
    in the mumble-server.ini is the same as before?
    The insteressting lines in my mumble-server.ini looks like this:

    To enable public server registration, the serverpassword must be blank, and

    this must all be filled out.

    The password here is used to create a registry for the server name;

    subsequent

    updates will need the same password. Don't lose your password.

    The URL is your own website, and only set the registerHostname for static IP

    addresses.

    registerName=Freddys Mumble Server
    registerPassword=##############
    registerUrl=http://www.bund-des-westens.de.vu/
    registerHostname=kruegerfreddy.homelinux.com

     
  • I just installed from scratch, but same issue....
    here is my log:

    <W>2009-12-18 22:06:16.642 Binding to address xxx.xxx.xxx.xxx  
    <W>2009-12-18 22:06:16.658 SSL: Added CA certificates from system store 'Ca'  
    <W>2009-12-18 22:06:16.674 SSL: Added CA certificates from system store 'Root'  
    <W>2009-12-18 22:06:16.705 SSL: Added CA certificates from system store
    'AuthRoot'  
    <W>2009-12-18 22:06:16.705 ServerDB: Openend SQLite database
    G:/UserFiles/ADMIN/murmur.sqlite  
    <W>2009-12-18 22:06:16.720 Meta: Failed to load qWave.dll, no QoS available  
    <W>2009-12-18 22:06:18.752 DBus registration succeeded  
    <W>2009-12-18 22:06:18.783 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 21013"
    running  
    <W>2009-12-18 22:06:18.783 Murmur 1.2.1 (718da1) running on Win: 5.2.3790.0:
    Booting servers  
    <W>2009-12-18 22:06:18.970 1 => Server listening on 118.127.0.235:21013  
    <W>2009-12-18 22:06:19.049 1 => Generating new server certificate.  
    <W>2009-12-18 22:06:20.471 1 => Announcing server via bonjour  
    <W>2009-12-18 22:07:59.284 1 => <1:(-1)> New connection: 58.165.113.234:59121  
    <W>2009-12-18 22:07:59.518 1 => <1:(-1)> Connection closed: The remote host
    closed the connection  
    <W>2009-12-18 22:08:00.924 1 => <2:(-1)> New connection: 58.165.113.234:59122  
    <W>2009-12-18 22:08:01.237 1 => <2:(-1)> Client version 1.2.0 (Win: 1.2.0)  
    <W>2009-12-18 22:08:01.331 1 => <2:Superuser(-1)> Rejected connection: Wrong
    password for user  
    <W>2009-12-18 22:08:01.409 1 => <2:Superuser(-1)> Connection closed:  
    <W>2009-12-18 22:08:03.112 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted  
    <W>2009-12-18 22:08:03.190 1 => Registration failed: HTTP request failed  
    <W>2009-12-18 22:10:33.160 1 => <1:(-1)> New connection: 58.165.113.234:59142  
    <W>2009-12-18 22:10:33.363 1 => <1:(-1)> Client version 1.2.0 (Win: 1.2.0)  
    <W>2009-12-18 22:10:33.441 1 => Starting voice thread  
    <W>2009-12-18 22:10:33.535 1 => CELT codec switch ffffffff8000000b 0 (prefer
    ffffffff8000000b)  
    <W>2009-12-18 22:10:33.613 1 => <1:SuperUser(0)> Authenticated  
    <W>2009-12-18 22:11:03.769 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted  
    <W>2009-12-18 22:11:03.847 1 => Registration failed: HTTP request failed  
    

    I replaced my Beta ini file with the Stable ini, so register settings are
    exactly the same:

    registerName= My Mumble 1.20
    
    registerPassword=xxxxxx  
    
    registerUrl=[http://mysite.net/](http://mysite.net/)  
    
    registerHostname=xxx.xxx.xxx.xxx  
    

    Any ideas, or changes since the beta in realtion to these settings? I didnt
    have bonjour installed for my beta server, but just installed it then to see
    if it made any difference...It didnt.
    I was thinking about manually removing the server certificate, anyone know
    where its stored and what murmur calls it?
    Im using windows 2003.

     
  • Hagen R.
    Hagen R.
    2009-12-18

    I have the same problem as yagermaster.

    My log:

    <W>2009-12-18 01:01:44.138 Initializing settings from F:/Mumble/murmur.ini
    (basepath F:/Mumble)
    <W>2009-12-18 01:01:44.146 SSL: Added CA certificates from system store 'Ca'
    <W>2009-12-18 01:01:44.149 SSL: Added CA certificates from system store 'Root'
    <W>2009-12-18 01:01:44.150 SSL: Added CA certificates from system store
    'AuthRoot'
    <W>2009-12-18 01:01:44.153 ServerDB: Openend SQLite database
    F:/Mumble/murmur.sqlite
    <W>2009-12-18 01:01:44.216 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502"
    running
    <W>2009-12-18 01:01:44.216 Murmur 1.2.1 (718da1) running on Win: 6.0.6002.0:
    Booting servers
    <W>2009-12-18 01:01:44.307 1 => Server listening on 0.0.0.0:64738
    <W>2009-12-18 01:01:55.718 1 => <1:(-1)> New connection: 188.40.95.141:63884
    <W>2009-12-18 01:01:55.719 Connection: Failed to add flow to QOS
    <W>2009-12-18 01:01:55.892 1 => <1:(-1)> Client version 1.2.1 (Win: 718da1)
    <W>2009-12-18 01:01:56.017 1 => <1:SuperUser(-1)> Rejected connection: Wrong
    password for user
    <W>2009-12-18 01:01:56.141 1 => <1:SuperUser(-1)> Connection closed:
    <W>2009-12-18 01:02:00.172 1 => <2:(-1)> New connection: 188.40.95.141:63888
    <W>2009-12-18 01:02:00.172 Connection: Failed to add flow to QOS
    <W>2009-12-18 01:02:00.287 1 => <2:(-1)> Client version 1.2.1 (Win: 718da1)
    <W>2009-12-18 01:02:00.371 1 => Starting voice thread
    <W>2009-12-18 01:02:00.470 1 => CELT codec switch ffffffff8000000b 0 (prefer
    ffffffff8000000b)
    <W>2009-12-18 01:02:00.545 1 => <2:SuperUser(0)> Authenticated
    <W>2009-12-18 01:03:25.583 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 01:03:25.674 1 => Registration failed: HTTP request failed
    <W>2009-12-18 01:04:20.492 1 => <3:(-1)> New connection: 88.71.135.253:50925
    <W>2009-12-18 01:04:20.703 1 => <3:(-1)> Client version 1.2.1 (Win: 718da1)
    <W>2009-12-18 01:04:20.881 1 => <3:MiskyWhixer(10)> Authenticated
    <W>2009-12-18 01:04:49.310 1 => <3:MiskyWhixer(10)> Connection closed: The
    remote host closed the connection
    <W>2009-12-18 02:06:12.376 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 02:06:12.473 1 => Registration failed: HTTP request failed
    <W>2009-12-18 03:06:46.378 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 03:06:46.457 1 => Registration failed: HTTP request failed
    <W>2009-12-18 04:08:25.982 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 04:08:26.081 1 => Registration failed: HTTP request failed
    <W>2009-12-18 05:12:54.777 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 05:12:54.876 1 => Registration failed: HTTP request failed
    <W>2009-12-18 06:14:58.562 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 06:14:58.633 1 => Registration failed: HTTP request failed
    <W>2009-12-18 07:16:16.371 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 07:16:16.479 1 => Registration failed: HTTP request failed
    <W>2009-12-18 08:20:34.138 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 08:20:34.219 1 => Registration failed: HTTP request failed
    <W>2009-12-18 09:24:55.932 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 09:24:56.023 1 => Registration failed: HTTP request failed
    <W>2009-12-18 10:12:54.331 1 => <4:(-1)> New connection: 79.201.154.253:49206
    <W>2009-12-18 10:12:54.686 1 => <4:(-1)> Client version 1.2.0 (Win: 1.2.0)
    <W>2009-12-18 10:12:54.852 1 => <4:BEAvR(5)> Authenticated
    <W>2009-12-18 10:27:39.721 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 10:27:39.812 1 => Registration failed: HTTP request failed
    <W>2009-12-18 10:37:07.742 1 => <4:BEAvR(5)> Connection closed: The remote
    host closed the connection
    <W>2009-12-18 11:27:44.538 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 11:27:44.612 1 => Registration failed: HTTP request failed
    <W>2009-12-18 12:31:49.317 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 12:31:49.399 1 => Registration failed: HTTP request failed
    <W>2009-12-18 13:34:50.106 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 13:34:50.179 1 => Registration failed: HTTP request failed
    <W>2009-12-18 14:35:17.162 1 => Registration: SSL Handshake error: The
    certificate is self-signed, and untrusted
    <W>2009-12-18 14:35:17.256 1 => Registration failed: HTTP request failed

    I have also tried to install from scratch, changed the Servername and
    registerPassword.
    But no success.

    I had also no such problems with the beta servers.

    Murmur is running on Win2008 x64.

     
  • hmmm, yes you have the exact same problem. Im glad im not the only one :P

    Lets hope someone can shed some light. Maybe its a problem with the stable
    windows build, as the beta worked fine with my current ini settings???

     
  • Hagen R.
    Hagen R.
    2009-12-28

    Ok, after installing the current beta version 1.2.1 (86f851) (from scratch)
    the problem still occurs.
    So if there is no one else with this problem or no one who can explain it, i
    think we have to search for it ourself.

    I did a IP packet trace with this result:
    !(http://miskywhixer.ath.cx/Bilder/Murmur_Serverlist_ssl.png)

    It seems like even the SSL login on mumble.hive.no (128.39.114.1) fails.
    But I have no idea how to change the certificate for this login.

     
  • had any luck with this one whisky?

     
  • Hagen R.
    Hagen R.
    2010-01-09

    Problem is solved with the 1.2.1 version.

     
  • great, will update now :)

     
  • Vali
    Vali
    2012-04-05

    I had the same murmur public registration “problem” so I’ll post “my
    solution”.

    A few lines from the (original) murmur.ini file:

    To enable public server registration, the serverpassword must be blank, and

    this must all be filled out.

    The password here is used to create a registry for the server name;

    subsequent

    updates will need the same password. Don't lose your password.

    The URL is your own website, and only set the registerHostname for static IP

    addresses.

    Only uncomment the 'registerName' parameter if you wish to give your "Root"

    channel a custom name.

    registerName=Mumble Server

    registerPassword=secret

    registerUrl=http://mumble.sourceforge.net/

    registerHostname=

    The “help” lines for these parameters are very confusing.

    The confusion begins within the first phrase: “must be blank” and immediately
    after “must all be filled”. So blank or filled ?

    Then, they tell us that “The password here is used to create a registry for
    the server name; subsequent updates will need the same password.” So now you
    begin to suspect that we might need a password here but you are not 100% sure
    yet…
    The answer is YES, we need to uncomment that (registerPassword) line and to
    put a password.

    The help for the registerName parameter – “Only uncomment the 'registerName'
    parameter if you wish to give your "Root" channel a custom name”, is not that
    foggy if you ignore the “Only” word from the beginning.
    Obviously there are no nameless murmur servers on their public list therefore
    this parameter MUST be activated…
    So YES, we need to uncomment that (registerName) line and baptize the server
    (be creative here!)

    Now comes the biggest confusion, guilty for many murmur server registration
    FAILURE, the registerUrl
    Well the “help” clearly states - “The URL is your own website”.
    THIS IS WRONG!!!
    You SHOULD NOT CHANGE that original
    http://mumble.sourceforge.net/” url if you
    want your server to be listed.

    Here is the registerUrl definition (from the “UPDATED” sourceforge website!):
    registerUrl
    This points to a URL to the website for the server. Put your group's website,
    your sponsor's website, or the website where users can self-administrate with
    the server. They can right-click on your server in the registration list to
    access this URL.
    registerUrl=http://mumble.sourceforge.net/

    So this is beyond a lousy help. It’s a conspiracy! (That’s why the public list
    is almost empty compared to the number of downloads…)
    You must uncomment that (registerUrl) line but you must_not_change the
    original registrar address.
    It should be/remain like this:
    registerUrl=http://mumble.sourceforge.net/

    Now about the “registerHostname “ parameter.
    The “help” says “and only set the registerHostname for static IP addresses”.
    You see? The combination “and only” force you to believe that you must type an
    IP address or else it will not work...
    Not true! You SHOULD put your DNS_hostname (don’t have one? then read about
    dynamic dns).
    If you can ping your mydnshostname.whateverdomain.com (from another internet
    address) then it will work.
    Something like this:
    registerHostname=mydnshostname.whateverdomain.com

    There is ANOTHER COMPULSORY CONDITION if you want your Murmur server to be
    registered/listed:
    Whatever value you type in the “registerHostname” parameter, must be PINGABLE
    from the internet (or at least from the sourceforge.net domain)

    Here is (some) of the code that conditions the initial registration (of your
    murmur server) and ulterior updates:
    ……..
    void Server::initRegister() {
    connect(&qtTick, SIGNAL(timeout()), this, SLOT(update()));

    if (! qsRegName.isEmpty()) {
    if (!qsRegName.isEmpty() && !qsRegPassword.isEmpty() && qurlRegWeb.isValid()
    && qsPassword.isEmpty() && bAllowPing)
    qtTick.start((60 + (qrand() % 120))* 1000);
    else
    log("Registration needs nonempty 'registername', 'registerpassword' and
    'registerurl', must have an empty 'password' and allowed pings.");
    } else {
    log("Not registering server as public");
    }
    }

    void Server::update() {
    if (qsRegName.isEmpty() || qsRegPassword.isEmpty() || !qurlRegWeb.isValid() ||
    !qsPassword.isEmpty() || !bAllowPing)
    return;

    // When QNAM distinguishes connections by client cert, move this to Meta
    if (! qnamNetwork)
    qnamNetwork = new QNetworkAccessManager(this);

    qtTick.start(1000 * (60 * 60 + (qrand() % 300)));
    ……..

    So as you can see in if (!qsRegName.isEmpty() && !qsRegPassword.isEmpty() &&
    qurlRegWeb.isValid() && qsPassword.isEmpty() && bAllowPing)
    The registration depends on
    registerName not beign empty,
    registerPassword not beign empty,
    registerUrl not beign empty AND NOT different from
    http://mumble.sourceforge.net/
    registerPassword not beign empty,
    AND bAllowPing (aka to ping and to be be pingable)

    The End

    more seo focus
    murmur problem registration public internet list listing not listed mumble
    cannot see does not appear missing registerUrl registerHostname registerName
    registerPassword waited but nothing ping ok however public server registration
    registered issue

     
  • Mikkel Krautz
    Mikkel Krautz
    2012-04-05

    The help text is referring to two different passwords. One is the
    'serverpassword' (the server's password) and the other one is the registration
    password. For a server to be considered for the public list, it must not
    have a server password.

    I'm personally not convinced that it's too confusing, but I agree that adding
    a remark describing what the serverpassword is could make it clearer.

    There's nothing that requires setting the registerUrl to
    http://mumble.sourceforge.net/, and in
    fact, you can find many public servers on the list where that isn't the case.

     
  • Nothing in the code forces you to set registerURL to
    http://mumble.sourceforge.net/, it can be
    any valid URL and registerHostname can be empty (which is ok for most servers)
    or a host name that points to the same IP address as your server.

     
  • fwaggle
    fwaggle
    2012-04-05

    So as you can see in if (!qsRegName.isEmpty() && !qsRegPassword.isEmpty() &&
    qurlRegWeb.isValid() && qsPassword.isEmpty() && bAllowPing)
    The registration depends on
    registerName not beign empty,
    registerPassword not beign empty,
    registerUrl not beign empty AND NOT different from
    http://mumble.sourceforge.net/
    registerPassword not beign empty,
    AND bAllowPing (aka to ping and to be be pingable)

    Swing and a miss. For clarity, this is how it's enforced for registration (at
    least as far as I'm aware, there may be other caveats):

    1. AllowPing must be true (if you register your server then set "allowping=false" then chances are it won't make it through the filters in the default client anyway, so you're wasting space on the list server).
    2. password must be empty. This refers to the server password for unregistered users, which is a sane requirement: the list server is a list for public servers, not a phonebook to look up your secret hangout.
    3. registername must be non-empty. This is how the list server presents your server in the list, and is required.
    4. If registerurl is set, it must be valid. Note that the list server is _not _hosted on the SF domain, and that's not what the purpose of registerurl is - it's a link that the client can spawn when you right-click the specified server in the list, ostensibly so you can register yourself to it (at least I gather that was the old purpose, you pointed registerURL at wherever you hosted register.pl). Most folks just put their website, and some commercial hosts lock it to the host's URL.
    5. registerpassword must be non-empty. This is to stop impersonation - it doesn't matter what this is set to, but you can't for example change the IP address of your listing if this isn't the same (if you re-install, you can't use the same registerName entry unless you use the same registerPassword).
    6. If registerHostname is set, it must be a pingable representation of the server. You don't have to set it (your server will just be listed by IP address instead), but if it's set it has to be resolvable and pingable from the internet.

    Finally, a note about the error messages that the registration script returns:

    1. If the error message begins with "Registration: SSL Handshake error:" then something went wrong during SSL negotiation between your server and the list server. The most likely culprit with this is things like certs signed by authorities that aren't recognized (I'm not sure if CACert is or not), or if your server suddenly starts doing it after you upgraded OpenSSL you need to upgrade Murmur as well.
    2. If the error message begins with "Registration failed:" it's a network-level error. "host not found" means that for whatever reason your server couldn't resolve mumble.hive.no, "connection refused" or something of that nature means that the list server may be down, that sort of thing.
    3. If the error message begins simply with "Registration:" it's a response from the server. If you get something like "host not found" here, it means that mumble.hive.no couldn't resolve your hostname. If you get "connection refused" here, it means that your server is blocking mumble.hive.no (say, port forwarding incorrectly configured).
    4. If it's worked, you'll get "Registration:" (response from the server) with either something like "Registration successful" or "Registration updated".
     
    • Jeffrey Horn
      Jeffrey Horn
      2013-12-07

      Update: After waiting about 10 minutes, the server finally showed up in the public list. Thanks for the help.

      If registerurl is set, it must be valid. Note that the list server is _not _hosted on the SF domain, and that's not what the purpose of registerurl is - it's a link that the client can spawn when you right-click the specified server in the list, ostensibly so you can register yourself to it (at least I gather that was the old purpose, you pointed registerURL at wherever you hosted register.pl). Most folks just put their website, and some commercial hosts lock it to the host's URL.

      Thanks, this was helpful. However, I commented out this line, noting the "if" at the beginning of your advice. That causes the following error:

       Registration needs nonempty 'registername', 'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.
      

      So, setting this to http://mumble.sourceforge.net/ will work, since it returns an HTTP 200 response. I thought it would work with a 404, but apparently not.

      Regardless, I'm still having issues registering my server. No error messages in log, so I'm at a loss for how to continue. If you could look at my config, any advice would be appreciated.

       
      Last edit: Jeffrey Horn 2013-12-07
  • Vali
    Vali
    2012-04-12

    I was wrong and I apologize for :
    “registerUrl … You SHOULD NOT CHANGE that original
    http://mumble.sourceforge.net/” url if you
    want your server to be listed.”
    THIS IS NOT TRUE !
    Why did I believe that? Well, after three days of waiting for my server to be
    registered (listed), I started to play with those parameters (including
    putting back
    registerUrl=http://mumble.sourceforge.net/ )
    and suddenly my server was listed. THIS WAS A PURE COINCIDENCE!
    Now I’m sure of that (registerUrl coincidence) because after posting here “my
    solution”, the mkrautz (thank you) told me that registerUrl doesn’t
    require a “certain” url.
    Frankly, when I said that, I thought that this parameter tells Murmur
    server where to send the requests for registration
    but then, after some
    more code digging I found that the “registration address” is embedded into the
    code and it is: mumble.hive.no
    So I’ve tested it with my own url and it worked! So in my case, it was
    SOMETHING ELSE that finally triggered the registration.

    Another wrong affirmation I made was “must be PINGABLE from the internet (or
    at least from the sourceforge.net domain)”. THIS IS NOT TRUE either!
    If your DNS can resolve mumble.hive.no ( ping mumble.hive.no ) then it
    should work

    Since then, my server was on the list BUT from time to time it disappeared for
    a day or so…?!
    Today it was missing and the log was saying: “Registration failed: Host not
    found“

    I immediately pinged mumble.hive.no and to my surprise, the DNS didn’t
    resolve it!
    I changed my first dns to 8.8.8.8 and now everything is working!
    However, a question remains: why my dns is doing that?