Insane cpu usage ubuntu

Help
2014-02-13
2014-02-13
  • Hi,

    I am running xubuntu 13.10. Mumble has an insanely high cpu usage.

    When I open up htop Mumble is running at 112% on one process and 20% on another.
    I've attempted to change my sample rate from 44.1k to 48k in
    /etc/pulse/daemon.conf
    I've both default-sample-rate = 44100 and default-sample-rate = 48000 (killing/restarting)
    pulseaudio, and neither seem to lower my cpu usage.

    I've also fiddled with the quality of the stream it from 8 kb/s all the way to 96 kb/s.
    As well as the audio packet values .... nothing seems to change it.

    I even purchased a blue yeti usb mic to see if it had to do with my sound card.

    Here is the output of /cat/cpuinfo
    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 20
    model : 2
    model name : AMD E-450 APU with Radeon(tm) HD Graphics
    stepping : 0
    microcode : 0x5000119
    cpu MHz : 825.000
    cache size : 512 KB
    physical id : 0
    siblings : 2
    core id : 0
    cpu cores : 2
    apicid : 0
    initial apicid : 0
    fpu : yes
    fpu_exception : yes
    cpuid level : 6
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc extd_apicid aperfmperf pni monitor ssse3 cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch ibs skinit wdt arat hw_pstate npt lbrv svm_lock nrip_save pausefilter
    bogomips : 3293.05
    TLB size : 1024 4K pages
    clflush size : 64
    cache_alignment : 64
    address sizes : 36 bits physical, 48 bits virtual
    power management: ts ttp tm stc 100mhzsteps hwpstate

    processor : 1
    vendor_id : AuthenticAMD
    cpu family : 20
    model : 2
    model name : AMD E-450 APU with Radeon(tm) HD Graphics
    stepping : 0
    microcode : 0x5000119
    cpu MHz : 825.000
    cache size : 512 KB
    physical id : 0
    siblings : 2
    core id : 1
    cpu cores : 2
    apicid : 1
    initial apicid : 1
    fpu : yes
    fpu_exception : yes
    cpuid level : 6
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc extd_apicid aperfmperf pni monitor ssse3 cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch ibs skinit wdt arat hw_pstate npt lbrv svm_lock nrip_save pausefilter
    bogomips : 3293.05
    TLB size : 1024 4K pages
    clflush size : 64
    cache_alignment : 64
    address sizes : 36 bits physical, 48 bits virtual
    power management: ts ttp tm stc 100mhzsteps hwpstate

    Any help would be greatly appreciated,
    Erm

     
  • Natenom
    Natenom
    2014-02-13

    Disable echo cancellation in Configure -> Audio Input as this causes much CPU usage.

    There is also an unofficial patch which turns off audio input when you are muted/deafened, see https://github.com/mumble-voip/mumble/pull/171.

     
  • I guess I should have also mentioned that I have attempted to enable/disable
    echo cancellation.

    Here's my deamon.conf file. Perhaps there is something here that I'm not seeing that you might notice.

    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify
    # it under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, write to the Free Software
    # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
    # USA.
    
    ## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
    ## more information. Default values are commented out.  Use either ; or # for
    ## commenting.
    
    ; daemonize = no
    ; fail = yes
    ; allow-module-loading = yes
    ; allow-exit = yes
    ; use-pid-file = yes
    ; system-instance = no
    ; local-server-type = user
    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    ; lock-memory = no
    ; cpu-limit = no
    
    ; high-priority = yes
    ; nice-level = -11
    
    ; realtime-scheduling = yes
    ; realtime-priority = 5
    
    ; exit-idle-time = 20
    ; scache-idle-time = 20
    
    ; dl-search-path = (depends on architecture)
    
    ; load-default-script-file = yes
    ; default-script-file = /etc/pulse/default.pa
    
    ; log-target = auto
    ; log-level = notice
    ; log-meta = no
    ; log-time = no
    ; log-backtrace = 0
    
    resample-method = speex-float-1
    ; enable-remixing = yes
    ; enable-lfe-remixing = no
    
    flat-volumes = no
    
    ; rlimit-fsize = -1
    ; rlimit-data = -1
    ; rlimit-stack = -1
    ; rlimit-core = -1
    ; rlimit-as = -1
    ; rlimit-rss = -1
    ; rlimit-nproc = -1
    ; rlimit-nofile = 256
    ; rlimit-memlock = -1
    ; rlimit-locks = -1
    ; rlimit-sigpending = -1
    ; rlimit-msgqueue = -1
    ; rlimit-nice = 31
    ; rlimit-rtprio = 9
    ; rlimit-rttime = 1000000
    
    ; default-sample-format = s16le
    ; default-sample-rate = 44100
    ; default-sample-rate = 48000
    default-sample-rate = 48000
    ; alternate-sample-rate = 48000
    ; default-sample-channels = 2
    ; default-channel-map = front-left,front-right
    
    default-fragments = 8
    default-fragment-size-msec = 10
    
    ; enable-deferred-volume = yes
    deferred-volume-safety-margin-usec = 1
    ; deferred-volume-extra-delay-usec = 0