Murmur dont use the Port from Config

Help
ozontec
2008-01-21
2012-10-30
  • ozontec
    ozontec
    2008-01-21

    Hallo,
    ich have now murmur1.1.2 installet and murmur will not use the given Port from Config.
    I must hardcode the Port in the Meta.cpp

    Is this a Bug or Feature?

     
    • Works now, had to use an absolute path to specify the ini-file. Sorry for the confusion, please keep up with the good work :)

       
    • It sounds like your murmur isn't using the same config file that you are editing. Run it in verbose mode and verify.

       
    • ozontec
      ozontec
      2008-01-21

      It is the same Config. Some Settings (DB or WelcomeText) works.

      I Test it now with a different Port and it works.
      I am confused!

      Here is my log;

      <W>2008-01-21 20:40:32.284 Initializing settings from /home/ozon/atf2.ini
      <W>2008-01-21 20:40:32.531 DBus registration succeeded
      <W>2008-01-21 20:40:32.672 1 => Server listening on port 64738
      <W>2008-01-21 20:40:46.785 1 => Registration needs nonempty name, password and url, and the server must not be
      password protected.
      <W>2008-01-21 20:40:46.790 1 => Old autogenerated certificate is unusable for registration, invalidating it
      <W>2008-01-21 20:40:46.793 1 => Certificate specified, but failed to load.
      <W>2008-01-21 20:40:46.813 1 => Generating new server certificate.
      <W>2008-01-21 20:43:20.177 Caught SIGTERM, exiting
      <W>2008-01-21 20:43:20.177 Killing running servers
      <W>2008-01-21 20:43:20.188 1 => Stopped
      <W>2008-01-21 20:43:20.190 Shutting down
      <W>2008-01-21 20:44:05.311 Initializing settings from /home/ozon/atf2.ini
      <W>2008-01-21 20:44:05.342 DBus registration succeeded
      <W>2008-01-21 20:44:05.410 1 => Server listening on port 64738
      <W>2008-01-21 20:44:21.367 1 => Registration needs nonempty name, password and url, and the server must not be
      password protected.
      <W>2008-01-21 20:44:41.950 Caught SIGTERM, exiting
      <W>2008-01-21 20:44:41.951 Killing running servers

      Here i compiled murmur new with the Hardcodet Port .... the log say
      <W>2008-01-21 20:53:20.943 Initializing settings from /home/ozon/atf2.ini
      <W>2008-01-21 20:53:20.972 DBus registration succeeded
      <W>2008-01-21 20:53:21.020 1 => Server listening on port 64739

       
    • Yup, experienced the same problem on one of my systems (using the precompiled statically linked murmur provided by the sf.net mirror).

       
      • I just tested it, and it works fine for me. Please post your ini file and a log of './murmur.x86 -fg -v -ini blabla.ini'