#5 mbusb gambas error

v1.0_(example)
closed
nobody
None
5
2012-11-01
2012-08-30
Peter Schmidt
No

I'm running debian sid, the package installed fine, but when I run the program I get an error (in terminal) saying:

ERROR: #2: Cannot load class 'mbusb': Bytecode too recent. Please upgrade Gambas.

Is there another dependency to this?

Discussion

  • sundar_ima
    sundar_ima
    2012-09-01

    What is the version of gambas3 available in repo? Make sure that you have the latest version available in the repo.

     
  • Peter Schmidt
    Peter Schmidt
    2012-09-01

    There's gambas 3.1.-2, but there's also a good 30 or so packages related to gambas and some of them have a lot of dependencies so I'd like to know exactly which I need.

     
  • sundar_ima
    sundar_ima
    2012-09-03

    Ok. I have compiled the latest version (5.4) with Gambas 3.2.1. Here are the gambas3 dependency packages required by multibootusb gambas3-runtime, gambas3-gb-image, gambas3-gb-gtk, gambas3-gb-form. Try to remove old packages of gambas3 (mentioned above), update repo with latest gambas3 (version 3.2.1) then reinstall the multibootusb 5.4. If this is not working then try to install and run multibootusb 4.8 or 5.0 and report here.

    Feedback on this would be helpful for others too.

     
  • sundar_ima
    sundar_ima
    2012-10-24

    This bug has been fixed in version 5.8

     
  • sundar_ima
    sundar_ima
    2012-11-01

    • status: open --> closed
    • milestone: --> v1.0_(example)