But you should use the msys2 pacman build system. Then it is just makepkg-mingw from the right folder.

On Apr 18, 2014 5:06 PM, "Alexx83" <lexx83@users.sf.net> wrote:

./configure --build=i686-w64-mingw32 --host=i686-w64-mingw32


[tickets:#32] mingw python can not run in interactive mode

Status: open
Milestone: 1.0
Created: Fri Apr 11, 2014 07:32 AM UTC by LiTuX
Last Updated: Fri Apr 18, 2014 03:14 PM UTC
Owner: nobody

I found this issue months ago (again, sorry for late). I've installed msys-python2, msys-python3, mingw-x86_64-python2, mingw-x86_64-python3. Some of them are installed because of dependency. This days, I mainly works with mingw-x86_64-python2 (Because msys version do not have a pip package :P).

At first, none of those python works correctly. For the msys version, run python/python2/python2.7/python3/python3.3/python3.3m will back to bash without any error message (This issue does not exist any more in the up-to-date version).

But for the mingw version, issue is still there. Type python(2 or 3) in bash or cmd then enter, python displays its version information then the prompt >>>, then quit without error. Running python with - got the same result. These days I used the special file in windows for an interactive python: python con as a workaround.


Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/msys2/tickets/32/

To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/