#51 Problems installing qt-creator

1.0
open
Alexx83
None
2014-12-02
2014-06-27
Angelo Graziosi
No

I did this:

$ pacman -S mingw-w64-x86_64-qt-creator
risoluzione delle dipendenze in corso...
looking for conflicting packages...

Pacchetti (4) mingw-w64-x86_64-qbs-1.2.1-1 mingw-w64-x86_64-qt5-5.3.1-1
mingw-w64-x86_64-qtbinpatcher-2.1.0-1
mingw-w64-x86_64-qt-creator-3.1.2-2

Dimensione totale dei pacchetti da scaricare: 439,35 MiB
Dimensione totale dei pacchetti da installare: 2493,86 MiB

:: Vuoi procedere con l'installazione? [S/n] s
:: Download dei pacchetti in corso...
mingw-w64-x86_64-qt... 190,9 KiB 391K/s 00:00 [######################] 100%
mingw-w64-x86_64-qt... 411,9 MiB 948K/s 07:25 [######################] 100%
errore: impossibile scaricare il pacchetto 'mingw-w64-x86_64-qt5-5.3.1-1-any.pkg.tar.xz' da 148.251.42.38 : FTP response timeout
errore: impossibile scaricare il pacchetto 'mingw-w64-x86_64-qt5-5.3.1-1-any.pkg.tar.xz' da downloads.sourceforge.net : HTTP server doesn't seem to support byte ranges. Cannot resume.
attenzione: impossibile scaricare alcuni file
mingw-w64-x86_64-qb... 973,9 KiB 744K/s 00:01 [######################] 100%
mingw-w64-x86_64-qt... 26,3 MiB 948K/s 00:28 [######################] 100%
errore: impossibile eseguire l'operazione richiesta (errore inaspettato)
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

and retrying does not help:

$ pacman -S mingw-w64-x86_64-qt-creator
risoluzione delle dipendenze in corso...
looking for conflicting packages...

Pacchetti (4) mingw-w64-x86_64-qbs-1.2.1-1 mingw-w64-x86_64-qt5-5.3.1-1
mingw-w64-x86_64-qtbinpatcher-2.1.0-1
mingw-w64-x86_64-qt-creator-3.1.2-2

Dimensione totale dei pacchetti da installare: 2493,86 MiB

:: Vuoi procedere con l'installazione? [S/n] s
(4/4) verifica delle chiavi presenti nel porta... [######################] 100%
(4/4) verifica dell'integrità dei pacchetti [######################] 100%
errore: impossibile eseguire l'operazione richiesta (il pacchetto non è valido oppure è corrotto)
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

(in short, the package is corrupted...)

NOW what should I do?

Thanks,
Angelo.

Discussion

  • Alexx83
    Alexx83
    2014-06-28

    Wait new release because I find some issues with Qt5

     
  • Alexx83
    Alexx83
    2014-06-28

    • assigned_to: Alexx83
     
  • Alexx83
    Alexx83
    2014-07-01

    • status: open --> closed
     
  • Alexx83
    Alexx83
    2014-07-01

    Fixed.

     
    • I am afraid.. but I still get this :

      $ pacman -Syu
      :: Sincronizzazione dei database in corso...
      mingw32 126,1 KiB 323K/s 00:00 [######################] 100%
      mingw64 126,5 KiB 266K/s 00:00 [######################] 100%
      msys 96,4 KiB 279K/s 00:00 [######################] 100%
      :: Aggiornamento del sistema in corso...
      :: Vuoi sostituire msys2-base con msys/filesystem? [S/n] s
      risoluzione delle dipendenze in corso...
      looking for conflicting packages...

      Pacchetti (6) bash-4.3.018-3 filesystem-2014.07-1 liblzo2-2.08-1
      mingw-w64-x86_64-gnutls-3.3.5-1 mingw-w64-x86_64-lzo2-2.08-1
      msys2-base-1.1-9 [rimozione]

      Dimensione totale dei pacchetti da scaricare: 2,60 MiB
      Dimensione totale dei pacchetti da installare: 15,13 MiB
      Dimensione netta dell'aggiornamento: 0,11 MiB

      :: Vuoi procedere con l'installazione? [S/n] s
      :: Download dei pacchetti in corso...
      [...]
      attenzione: /etc/bash.bashrc saved as /etc/bash.bashrc.pacorig
      attenzione: /etc/bash.bash_logout saved as /etc/bash.bash_logout.pacorig
      attenzione: /etc/profile saved as /etc/profile.pacorig
      attenzione: /etc/skel/.bashrc saved as /etc/skel/.bashrc.pacorig
      attenzione: /etc/skel/.bash_profile saved as /etc/skel/.bash_profile.pacorig

      (which seems OK...), and after a "pacman -Sc" :

      $ pacman -S mingw-w64-x86_64-qt-creator
      risoluzione delle dipendenze in corso...
      looking for conflicting packages...

      Pacchetti (5) mingw-w64-x86_64-icu-debug-libs-53.1-4
      mingw-w64-x86_64-qbs-1.2.1-1 mingw-w64-x86_64-qt5-5.3.1-2
      mingw-w64-x86_64-qtbinpatcher-2.1.0-1
      mingw-w64-x86_64-qt-creator-3.1.2-3

      Dimensione totale dei pacchetti da scaricare: 509,55 MiB
      Dimensione totale dei pacchetti da installare: 2856,46 MiB

      :: Vuoi procedere con l'installazione? [S/n] s
      :: Download dei pacchetti in corso...
      mingw-w64-x86_64-ic... 33,7 MiB 963K/s 00:36 [######################] 100%
      mingw-w64-x86_64-qt... 190,9 KiB 377K/s 00:01 [######################] 100%
      mingw-w64-x86_64-qt... 448,4 MiB 974K/s 07:51 [######################] 100%
      errore: impossibile scaricare il pacchetto 'mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz' da 148.251.42.38 : FTP response timeout
      errore: impossibile scaricare il pacchetto 'mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz' da downloads.sourceforge.net : HTTP server doesn't seem to support byte ranges. Cannot resume.
      attenzione: impossibile scaricare alcuni file
      mingw-w64-x86_64-qb... 973,9 KiB 706K/s 00:01 [######################] 100%
      mingw-w64-x86_64-qt... 26,3 MiB 949K/s 00:28 [######################] 100%
      errore: impossibile eseguire l'operazione richiesta (errore inaspettato)
      Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

      Ciao,
      Angelo.

       
  • Ray Donnelly
    Ray Donnelly
    2014-07-01

    rm -f /var/cache/pacman/pkg/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz

    .. then try again.

     
    • It still does not work:

      $ rm -rf /var/cache/pacman/pkg/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz.part

      (I think you mean removing the .part file)

      $ pacman -S mingw-w64-x86_64-qt-creator risoluzione delle dipendenze in corso...
      looking for conflicting packages...

      Pacchetti (5) mingw-w64-x86_64-icu-debug-libs-53.1-4
      mingw-w64-x86_64-qbs-1.2.1-1 mingw-w64-x86_64-qt5-5.3.1-2
      mingw-w64-x86_64-qtbinpatcher-2.1.0-1
      mingw-w64-x86_64-qt-creator-3.1.2-3

      Dimensione totale dei pacchetti da scaricare: 448,37 MiB
      Dimensione totale dei pacchetti da installare: 2856,46 MiB

      :: Vuoi procedere con l'installazione? [S/n] s
      :: Download dei pacchetti in corso...
      mingw-w64-x86_64-qt... 448,4 MiB 965K/s 07:56 [######################] 100%
      errore: impossibile scaricare il pacchetto 'mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz' da 148.251.42.38 : FTP response timeout
      errore: impossibile scaricare il pacchetto 'mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz' da downloads.sourceforge.net : HTTP server doesn't seem to support byte ranges. Cannot resume.
      attenzione: impossibile scaricare alcuni file
      errore: impossibile eseguire l'operazione richiesta (si è verificato un errore della libreria di download)
      Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

      After it reaches the 100% of download, it seems to hang for about 20-30 seconds, then the error messages which, translating, mean

      error: cannot download the packages mingw-w64-x86_64-qt5... from 148.251.42.38 : FTP response timeout

      error: cannot download the packages mingw-w64-x86_64-qt5... from downloads.sourceforge.net : HTTP server doesn't seem to support byte ranges. Cannot resume.

      Anyway, I can download it directly:

      $ wget --content-disposition http://sourceforge.net/projects/msys2/files/REPOS/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz/download
      --2014-07-01 21:42:05-- http://sourceforge.net/projects/msys2/files/REPOS/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz/download
      Risoluzione di sourceforge.net (sourceforge.net)... 216.34.181.60
      Connessione a sourceforge.net (sourceforge.net)|216.34.181.60|:80... connesso.
      Richiesta HTTP inviata, in attesa di risposta... 302 Found
      Posizione: http://downloads.sourceforge.net/project/msys2/REPOS/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz?r=&ts=1404243730&use_mirror=netcologne [segue]
      --2014-07-01 21:42:05-- http://downloads.sourceforge.net/project/msys2/REPOS/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz?r=&ts=1404243730&use_mirror=netcologne
      Risoluzione di downloads.sourceforge.net (downloads.sourceforge.net)... 216.34.181.59
      Connessione a downloads.sourceforge.net (downloads.sourceforge.net)|216.34.181.59|:80... connesso.
      Richiesta HTTP inviata, in attesa di risposta... 302 Found
      Posizione: http://netcologne.dl.sourceforge.net/project/msys2/REPOS/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz [segue]
      --2014-07-01 21:42:06-- http://netcologne.dl.sourceforge.net/project/msys2/REPOS/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz
      Risoluzione di netcologne.dl.sourceforge.net (netcologne.dl.sourceforge.net)... 78.35.24.46, 2001:4dd0:1234:6::5f
      Connessione a netcologne.dl.sourceforge.net (netcologne.dl.sourceforge.net)|78.35.24.46|:80... connesso.
      Richiesta HTTP inviata, in attesa di risposta... 200 OK
      Lunghezza: 470146976 (448M) [application/octet-stream]
      --2014-07-01 21:42:06-- http://netcologne.dl.sourceforge.net/project/msys2/REPOS/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz
      Connessione a netcologne.dl.sourceforge.net (netcologne.dl.sourceforge.net)|78.35.24.46|:80... connesso.
      Richiesta HTTP inviata, in attesa di risposta... 200 OK
      Lunghezza: 470146976 (448M) [application/octet-stream]
      Salvataggio in: "mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz"

      100%[======================================>] 470.146.976 988KB/s in 7m 46s

      2014-07-01 21:49:52 (986 KB/s) - "mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz" salvato [470146976/470146976]

      and its size is the same of the .part fole:

      $ ls -lrt /var/cache/pacman/pkg/*.part
      -rw-r--r-- 1 angelo None 470146976 1 lug 21.30 /var/cache/pacman/pkg/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz.part

      Ciao,
      Angelo.

       
    • I still tried this evening... but as I described in my previous replay, your suggestion does not work. So, unless you have other ideas, you should re-open this thicket.

       
  • Alexx83
    Alexx83
    2014-07-05

    Hmm. I'm successfully install it on some computers without your errors. I can't reproduce error.

     
  • Alexx83
    Alexx83
    2014-07-05

    • status: closed --> open
     
    • Thanks. BTW, I have

      $ cat /etc/pacman.d/mirrorlist.mingw64
      ##
      ## 64-bit Mingw-w64 repository mirrorlist
      ## Changed on 2014-05-24
      ##
      
      ## Primary
      Server = ftp://148.251.42.38/MINGW/x86_64
      
      ## Sourceforge.net
      Server = http://downloads.sourceforge.net/project/msys2/REPOS/MINGW/x86_64
      

      and both

      $ wget ftp://148.251.42.38/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz
      

      and

      $ wget http://downloads.sourceforge.net/project/msys2/REPOS/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz
      

      work fine. So I don't understand why pacman fails that way...

      Ciao,
      Angelo.

       
  • Alexx83
    Alexx83
    2014-07-17

    Is it still relevant?

     
    • It still fails as described, both if I try after a

      pacman -Sc
      

      and both is I remove the .part file and then re-try

      $ rm /var/cache/pacman/pkg/*part
      rm: rimuovere file regolare "/var/cache/pacman/pkg/mingw-w64-x86_64-qt5-5.3.1-any.pkg.tar.xz.part"? y
      
      $ pacman -S mingw-w64-x86_64-qt-creator
      risoluzione delle dipendenze in corso...
      looking for conflicting packages...
      
      Pacchetti (5) mingw-w64-x86_64-icu-debug-libs-53.1-4
                mingw-w64-x86_64-qbs-1.2.2-2  mingw-w64-x86_64-qt5-5.3.1-2
                mingw-w64-x86_64-qtbinpatcher-2.1.0-1
                mingw-w64-x86_64-qt-creator-3.1.2-5
      
      Dimensione totale dei pacchetti da scaricare:    448,37 MiB
      Dimensione totale dei pacchetti da installare:  2856,96 MiB
      
      :: Vuoi procedere con l'installazione? [S/n] s
      :: Download dei pacchetti in corso...
       mingw-w64-x86_64-qt...   448,4 MiB   981K/s 07:48 [######################] 100%
      
      HERE IT HANGS FOR A FEW SECONDS THEN...
      
      errore: impossibile scaricare il pacchetto 'mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz' da 148.251.42.38 : FTP response timeout
      errore: impossibile scaricare il pacchetto 'mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz' da downloads.sourceforge.net : HTTP server doesn't seem to support byte ranges. Cannot resume.
      attenzione: impossibile scaricare alcuni file
      errore: impossibile eseguire l'operazione richiesta (si è verificato un errore della libreria di download)
      Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
      

      I think I will not install qt-creator...

      Ciao,
      Angelo.

       
  • Alexx83
    Alexx83
    2014-07-17

    As workaround try rename part file after 100% downloading - remove ".part" from the end. And then run installing again

     
    • Yeah, that was my first thought but I would prefer it woks OB.

      Just a few minutes ago, perhaps we did a step forward..

      Indeed, as you remember, I wrote I can download that package directly with wget.. Using curl GIVES the same error I get with pacman,

      $ curl -O ftp://148.251.42.38/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                   Dload  Upload   Total   Spent    Left  Speed
      100  448M  100  448M    0     0   813k      0  0:09:24  0:09:24 --:--:--     0
      curl: (28) FTP response timeout
      

      Any chances pacman uses CURL to download packages?

      In the light of this, any other ideas to suggest?

      TIA,
      Angelo.

       
  • Alexx83
    Alexx83
    2014-07-17

    Yes, pacman linked with libcurl and use it to download packages.

     
  • Alexx83
    Alexx83
    2014-07-17

    I will update curl now to newest. Try to see if it helps

     
    • Just for completeness, I tried the above

      curl -O ftp:/...
      

      command from mingw64_shell.bat shell and there there wasn't the final FTP error : there it uses the curl from mingw-w64-x86_64-curl package, version 7.37.1 (while MSYS2 uses curl version 7.37.0).

      I will wait your update to see if it works.

      Thanks,
      Angelo.

       
  • Alexx83
    Alexx83
    2014-07-17

    I'm upload updates. Try update packages and see if it solve problem.

     
    • No, it does not help.

      Same issues... Also if I try running curl at command line to download the package.

      On Cygwin curl is at version 7.37.0 and there it gives the same error after downloading the package.

      Since this doesn't occur in mingw64, I start to think that it is related to the msys (cygwin) DLL.

      Ciao,
      Angelo.

       
  • Alexx83
    Alexx83
    2014-12-02

    Is it still relevant?

     
    • I decided not to install it, any more..

      In any case, if I do

      curl -O ftp://148.251.42.38/MINGW/x86_64/mingw-w64-x86_64-qt5-5.3.1-2-any.pkg.tar.xz
      

      it still produces

        % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                       Dload  Upload   Total   Spent    Left  Speed
      

      100 448M 100 448M 0 0 862k 0 0:08:52 0:08:52 --:--:-- 0curl: (28) FTP response timeout

      so, I doubt it will work for me..