Ajuda - Erro.

Help
giacomitti
2009-04-15
2013-04-23
  • giacomitti
    giacomitti
    2009-04-15

    O msn sai com o erro:
    Error 81000314: Your contact list is not available

    Alguem já passou por isso tem alguma idéia de como resolver?????

    Obrigado,
    Arnaldo.

    ACLs
    connect               : ALLOW
    log messages          : YES
    save_contacts         : YES

    listen on [0.0.0.0:1863]
    SQL: (DELETE FROM sb)
    SQL: (UPDATE contacts SET contact_status = 'OFF', contact_deny = contact_deny & ~4194304)
    SQL: (UPDATE users SET status = 'OFF')
    debug: connection from [192.168.1.100]
    connected to [messenger.hotmail.com:1863]
    [(null)] send to ns server ==> VER 1 MSNP18 MSNP17 CVR0

    [(null)] send to ns server ==> CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 14.0.8064.0206 msmsgs giacomitti@hotmail.com

    SQL: (UPDATE users SET last_seen = NOW(), last_addr = '192.168.1.100' WHERE email = 'giacomitti@hotmail.com')
    SQL: (SELECT contact_email, contact_dn, contact_uid, contact_status, contact_info, contact_flags, contact_flags2, contact_lists, contact_deny contact_chat FROM contacts WHERE email = 'giacomitti@hotmail.com')
    SQL: (SELECT connect FROM users WHERE email = 'giacomitti@hotmail.com')
    SQL: (SELECT save_msg FROM users WHERE email = 'giacomitti@hotmail.com')
    SQL: (SELECT save_contacts FROM users WHERE email = 'giacomitti@hotmail.com')
    SQL: (SELECT commands FROM users WHERE email = 'giacomitti@hotmail.com')
    [giacomitti@hotmail.com] send to ns server ==> USR 3 SSO I giacomitti@hotmail.com

    [giacomitti@hotmail.com] send to ns client ==> VER 1 MSNP18

    [giacomitti@hotmail.com] send to ns client ==> CVR 2 14.0.8064 14.0.8064 8.1.0178 http://msgr.dlservice.microsoft.com/download/5/2/E/52EB299A-E4DE-43E2-8D55-510D7FB03610/en/wlsetup-cvr.exe http://download.live.com/?sku=messenger

    listen on [192.168.1.1:28835]
    [giacomitti@hotmail.com] send to ns client ==> XFR 3 NS 192.168.1.1:28835 U D

    connected to [207.46.106.81:1863]

     
    • Qual é a versão do MSN Proxy e a versão do cliente que você está utilizando?

      Obrigado.

       
      • giacomitti
        giacomitti
        2009-04-15

        msn-proxy release     : msn-proxy-0.7a [$Id: msn-proxy.h 112 2009-03-15 17:30:28Z loos-br $]

        Windows Live Messenger: Version 2009 (Build 14.0.8064.206)

        Abraços,
        Giacomitti.

         
        • Você utiliza proxy na rede? Tem alguma URL sendo bloqueada quando o usuário tenta autenticar no MSN?
          Você possui outros clientes na rede? Eles conseguem visualizar os contatos corretamente?

          E por último: Você pode fazer um teste com o trunk do SVN?

          Obrigado.

           
          • giacomitti
            giacomitti
            2009-04-15

            Sem proxy na rede, não tem URL bloqueada, se eu tiro a regra do firewall do redirecionamento funciona normal (sem o msn-proxy).

            Posso sim, vou baixar ele do svn, e depois reporto o que aconteceu!

            Obrigado,
            Giacomitti.

             
          • giacomitti
            giacomitti
            2009-04-15

            mesmo problema com a versao do trunk, náo pode ter alguma coisa com as portas 25000-30000?

            Obrigado,
            Giacomitti.

             
    • Você tem como testar com algum outro cliente (aMSN, Emesene, Pidgin, ...)?

      Obrigado.

       
      • giacomitti
        giacomitti
        2009-04-15

        aledr,

        continua com o mesmo problema, vc que regras do firewall tem que estar abertas para as portas 25000-30000??

        Obrigado,
        Giacomitti.

         
    • O que é essa ultima linha no log que você passou?

      [giacomitti@hotmail.com] send to ns client ==> CVR 2 14.0.8064 14.0.8064 8.1.0178 http://msgr.dlservice.microsoft.com/download/5/2/E/52EB299A-E4DE-43E2-8D55-510D7FB03610/en/wlsetup-cvr.exe http://download.live.com/?sku=messenger

      Aparentemente o msn está tentando atualizar algo.
      Você baixou todas as atulizações do msn?
      Só para saber. Você configurou o proxy no internet explorer? Você está trabalhando com proxy transparente?
      Tentou remover totalmente o msn-proxy? Inclusive destruir a base e iniciar a instalação do zero?
      Verificou a versão das dependências do programa?

      Cordialmente;

      Claudir

       
    • Consegui gerar seu erro aqui. O sistema retornou:
      "Não foi possível encontrar sua lista de contatos" ou algo assim.
      Sabe como? Não informano no navegador o proxy.
      Aqui eu uso o squid como proxy qu está na mesma maquina que o msn-proxy.
      No gateway da maquina cliente informei o Ip da maquina onde está o msn-proxy e o squid, que era para estar trabalhando de forma transparente.
      Teste ai e poste os resultados aqui.

      Cordialmente;

      Claudir

       
      • giacomitti
        giacomitti
        2009-04-16

        Claudir,

        Estranho, vamos lá, não estou usando proxy. Uso o servidor dhcp do linux, o qual fornece os IPs para as maquinas, e o gateway é o mesmo IP do msn-proxy (que é o meu servidor linux), o qual está conectado via pppoe em um modem adsl.

        Se eu tiro a regra do redirect do firewall da porta 1863, o msn conecta normalmente sem erro algum. Se eu habilito a regra, e rodo o msn-proxy obtenho esse erro.

        Obrigado,
        Giacomitti.

         
    • Giacomitti, qual é a regra de redirecionamento que você está utilizando?

       
      • giacomitti
        giacomitti
        2009-04-16

        Na verdade, estou utilizando o shorewall com a regra:

        REDIRECT        loc             1863            tcp     1863

        todos os  pacotes tcp da rede loc (local) ele redireciona para o servidor.

        Abraços,
        Giacomitti.

         
        • Sua regra está correta...
          Deixa eu fazer mais algumas perguntas:
             Vocẽ já possuiu a versão 0.6 e atualizou para a 0.7?
             Vocẽ já tentou remover seu usuário e os respectivos contatos do banco de dados?

           
          • Quando migrou do 0.6 para 0.7, você rodou o ALTER TABLE ?

            na 0.7 tem uma mudança em uma tabela.

             
            • É justamente este o ponto! =D

               
          • giacomitti
            giacomitti
            2009-04-16

            Não, fiz uma instalação nova com o .tgz na 0.7 com tudo zerado, depois disso fiz uma outra instalação com a versão do trunk de ontem (15/04).

            E com as duas versões acontece o mesmo erro.

            Abraços,
            Giacomitti

             
    • Giacomitti, também trabalho com servidor DHCP, mas do windows Server. O que sei é que se não informo no internet explorer o proxy e a porta recebo este mesmo erro.
      Minha regra iptables é para proxy transparente e redirecionamento da porta 1863 para a propia 1863.
      Você não consegue informar em seu internet explorer, caso seja esse o broser, o Ip e a porta http do seu servidor para testar?

      Cordialmente;

      Claudir

       
      • giacomitti
        giacomitti
        2009-04-16

        Como eu nao tenho proxy na rede, se eu informar no internet explorere o gateway como proxy, ele vai sempre parar no servidor web interno.

        Estranho esse problema...

        Abracos,
        Giacomitti.