#357 Problem with LDAP Authentication

open
nobody
1
2014-04-08
2013-06-12
Jonas Ferreira
No

Hi everyone,

I have problem with LDAP Authentication. The LDAP Server is a Active Directory with Windows Server 2003.

About System:

MRBS 1.4.9
MySQL 5.5.30-cll
Linux jonas-fedora 3.7.9-104.fc17.i686 #1 SMP Sun Feb 24 19:33:52 UTC 2013 i686
PHP: 5.4.15

My config.inc.php:

$auth["session"] = "php";
$auth["type"] = "ldap";

$ldap_host = "10.20.0.11";
$ldap_port = 389;
$ldap_v3 = true;
$ldap_tls = false;
$ldap_base_dn = "ou=users,dc=mydomain,dc=com,dc=br";
$ldap_user_attrib = "uid";
$ldap_dn_search_attrib = "sAMAccountName";
$ldap_dn_search_dn = "cn=administrator,ou=users,dc=mydomain,dc=com,dc=br";
$ldap_dn_search_password = "password";
$ldap_get_user_email = false;
$ldap_email_attrib = 'mail';
$ldap_group_member_attrib = 'memberof';
$ldap_unbind_between_attempts = false;
$ldap_debug = true;
$ldap_disable_referrals = TRUE;

HTTPD error_log:
[Wed Jun 12 16:06:41 2013] [error] [client 127.0.0.1] authLdapAction: Got LDAP connection, referer: http://127.0.0.1/mrbs/web/admin.php
[Wed Jun 12 16:06:41 2013] [error] [client 127.0.0.1] authLdapAction: Result of initial bind is , referer: http://127.0.0.1/mrbs/web/admin.php
[Wed Jun 12 16:06:41 2013] [error] [client 127.0.0.1] authValidateUserCallback: base_dn 'ou=users,dc=roullier,dc=com,dc=br' dn '' user 'jonas.ferreira', referer: http://127.0.0.1/mrbs/web/admin.php
[Wed Jun 12 16:06:41 2013] [error] [client 127.0.0.1] authValidateUserCallback: Bind to '' failed, referer: http://127.0.0.1/mrbs/web/admin.php

Discussion


  • Anonymous
    2014-04-08

    Hello,
    I have the same problem, is there any solution?

     


Anonymous


Cancel   Add attachments