Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#337 LDAP auth problem..

open
nobody
LDAP (4)
1
2013-03-12
2013-03-12
Anonymous
No

Trying to get LDAP authentication working on MRBS.

Settings i made in the config.inc.php

$auth["type"] = "ldap";
$ldap_host = "test.net";
$ldap_port = 389;
$ldap_v3 = true;
$ldap_tls = false;
$ldap_base_dn = "ou=Service,ou=UserAccounts,dc=test,dc=net";
$ldap_dn_search_dn = "cn=DCB Tools,ou=Service,ou=UserAccounts,dc=test,dc=net";
$ldap_user_attrib = "sAMAccountName";
$ldap_dn_search_password = "XXXXXXXXX";
$ldap_disable_referrals = TRUE;
$ldap_debug = TRUE;

Error: When i try to authenticate.

[Tue Mar 12 14:56:19 2013] [error] [client 10.142.142.59] authLdapAction: Got LDAP connection, referer: http://10.142.142.57/mrbs/web/admin.php
[Tue Mar 12 14:56:19 2013] [error] [client 10.142.142.59] authLdapAction: Constructed dn 'sAMAccountName=magm,ou=Service,ou=UserAccounts,dc=test,dc=net' and user_search 'sAMAccountName=magm' using 'sAMAccountName', referer: http://10.142.142.57/mrbs/web/admin.php
[Tue Mar 12 14:56:19 2013] [error] [client 10.142.142.59] authValidateUserCallback: base_dn 'ou=Service,ou=UserAccounts,dc=test,dc=net' dn 'sAMAccountName=magm,ou=Service,ou=UserAccounts,dc=nsn-intra,dc=net' user 'magm', referer: http://10.142.142.57/mrbs/web/admin.php
[Tue Mar 12 14:56:19 2013] [error] [client 10.142.142.59] authValidateUserCallback: Bind to 'sAMAccountName=magm,ou=Service,ou=UserAccounts,dc=test,dc=net' failed, referer: http://10.142.142.57/mrbs/web/admin.php
[Tue Mar 12 14:56:19 2013] [error] [client 10.142.142.59] File does not exist: /var/www/html/favicon.ico

Kindly help us to proceed..
Thanks in advance.

Regards,
Maghesh

Discussion


Anonymous


Cancel   Add attachments