mplayerplug-in Support This Project

Jakie oprogramowanie jest potrzebne?

Aby używać mplayerplug-ina musisz mieć działającą instalację mplayera i ewentualnie dodatkowe kodeki. Jeżeli nie doinstalujesz dodatkowych kodeków, niektóre formaty zpisu multimediów nie będą obsługiwane. Mplayer w wersji 1.0pre5 jest wysoce wskazany, aczkolwiek najniższą obsługiwaną wersją jest 0.92.
Zalecane 'dodatki' do mplayera:

Jedyne co widzę to komunikat "mplayerplug-in buffering". O co chodzi?

Jest to bardzo częste pytanie. Zazwyczaj oznacza to, że strumień video, który starasz się obejrzeć, jest niedostępny dla mplayera, strumień jest uszkodzony, mplayer nie ma stosownego kodeka do odtworzenia tego formatu, masz błąd w konfiguracji  lub starą wersję mplayera.

mplayerplug-in buforuje 99% i staje

Takie zachowanie może mieć kilka przyczyn:

Na stronie about:plugins w Mozilli jest napisane, że [movie type] jest obsługiwany, ale viedeo [movie type] nie jest odtwarzane.

Cała praca związana z dekodowaniem i odtwarzaniem video jest wykonywana przez mplayera. Tak więc jeżeli występuje problem z konkretnym typem video zwykle oznacza to że:

Czy ta wtyczka działa z serwerami proxy?

Uaktualniono 10/3/2003 Począwszy od wersji 1.0pre2 wszystkie protokoły, które potrafi obsługiwać Mozilla (http,https,ftp,file, itd.) są obsługiwane prze Mozillę. Zatem jeżeli Mozilla jest skonfigurowana do pracy z serwerem proxy to wszystko powinno działać. Jedynym wyjątkiem są strumienie mms://, które nie są obsługiwane przez Moziilę. Rozwiązaniem w tym przypadku może być ustwienie obsługi proxy w samym mplayerze. Mplayer powinien brać pod uwagę zmienną środowiskową HTTP_PROXY.
HTTP_PROXY=http://your.proxy:80
export HTTP_PROXY

W niektórych konfiguracjach może być wymagane wpisanie zmiennej http_proxy małymi literami.
Rozwiązaniem może również być napisanie pomocniczego skryptu. Na przykład coś takiego powinno działać z serwerami socks proxy
#!/bin/sh
LD_PRELOAD=/usr/local/lib/libtsocks.so
export LD_PRELOAD
/usr/local/bin/mplayer.orig
skopiuj plik mplayer jako mplayer.orig
Zapisz skrypt jako /usr/local/bin/mplayer

Dlaczego ta wtyczka nie obsługuje niektórych strumieni video?

Niektóre strony zabezpieczają swoją zawartość mechanizmem ciasteczek (cookies) lub zmiennymi sesji (session variables). Ponieważ wtyczka przekazuje pozyskany adres URL do mplayera, mplayer może nie mieć niezbędnych mechanizmów autentykacji i nie może pobrać strumienia. Ten problem występuje zazwyczaj na płatnych stronach..

Jakie są (znane) problemy ze strumieniami video?

Uaktualniono10/3/2003 Jedynym problemem jest odtwarzanie stumieni z zabezpieczonych stron (wymagających autentykacji).

Obraz jest odtwarzany dwa razy, dostaję podwójny obraz i podwójny dzwięk.

Ten problem był obserwowany w Mozilli 1.0 i Galeonie 1.2.6. Rozwiązeniem jest uaktualnienie Mozilli do wersji 1.1 lub nowszej.

Jak mogę uruchomić tą wtyczkę w Operze?

Pobierz źródła, rozpaku i w katalogu ze źródłami wpisz takie polecenia:
./configure --enable-x  [--with-gecko-sdk={path} ]
make
cp mplayerplug-in.so /usr/lib/opera/plugins
ln -s /usr/lib/mozilla/libxpcom.so /usr/lib

Zawartość apple.com/trailers nie jest odtwarzana lub jest odtwarzana bez dźwięku

Jeżeli plik jest odniesienim do filmów w różnej jakości to może się zdarzyć, że odnośnik prowadzi do nieistniejącego strumiena video. Czasem pomaga ustawienie zmiennej konfiguracyjnej qt-speed na low lub high i odświerzenie strony.

Jeżeli zwiastun jest odtwarzany bez dźwięku, może to być spowodowane brakiem obsługi FAAD w maplayerze. FAAD jest dekoderem AC3, który jest niezbędny do zdekodowania dźwięku w niektórych plikach quicktime. Taki efekt może również się pojawić jeżeli brakuje kodeka do formatu w jakim jest zapisany dźwięk lub ten format nie jest obsługiwany.

Nie mogę skompilować mplayerplug-in pod Debianem

Zobacz błąd 1023442.  Znajdziesz tam opis błędu i rozwiązanie.
Ten błąd powinien być naprawiony w wersji 2.75 wtyczki.